KillSwitch Error When Creating Full Dump [M892]

Hello,

  1. Issue. A 1 line statement of the problem in the topic title- you expand it in section 6-8 Getting an Error when Creating Full Dump

  2. Diagnostics report as attachment to your post Yes It is added to Bug Report on bottom of Page.

  3. The full product and its version e.g. COMODO Firewall 7.0.308911.4080 7.0.312140.4101 (KillSwich same version)

  4. Your Operating System (32 or 64 bit) and ServicePack revision. and if using a virtual machine, which one. It is an Windows 7 Operating System 32 bit Running Service Pack 1

  5. List all the configuration changes you did. Are you using Default configuration? If no, whats the difference? Proactive Configuration

  6. Did you install over a previous version without uninstalling first, or import a previous configuration file? (please try to avoid doing these things until we are told it is safe) Yes, It was an Auto Update from 7.0.308911.4080

  7. Other Security, Sandboxing or Utility Software Installed I only have SpywareBlaster and Privdog

  8. Step by step description to reproduce the issue. Or if you cannot reproduce it, what you actually did before it happened, step by step. Yes, I tried this Process on CIS 6.3.302093.2976 and I got the same Result.
    This question is crucial as well. The most valuable report is the one with precise, separate, numbered, reproduction steps.
    i) 1. Once KillSwitch is full open. I choose any processes, then I right-click it. Check Capture 1
    ii) 2. Now I scroll down with Mouse arrow until I get to Create Dump. Check Capture 2
    iii) 3.Looking at Capture 2 I moved over and pressed Create Full Dump.
    4 Once I pressed Create Full Dump this showed check Capture 3
    5 I Pressed Save and this happened shown by Capture 4
    6 I tried it again by step 3 and step 4 and tried to remove it the Word System, but it would not let me.
    7. Therefore I tried once more, by adding and extra name after System, I added Capture after System and it showed the same as Capture 4
    8. So I tried a fresh go on cis down the list. however that made a Duplicate Icon of cis and it was greyed out. Look at Capture 5
    9 However that did make a dump file of cis only etc

  9. What actually happened when you carried out these steps Well you can see from Step 1 though to Step 5

  10. What you expected to see or happen when you carried out these steps, and why (if not obvious) I expected to see dump file from any of the Processes. however it only worked on cis only.

Please find the CISReport and Capture Pics from 1 to 5.

Thanks

Regards

Nigel

[attachment deleted by admin]

Strange. I wonder if there was perhaps a part of an older version of CCE which is interfering with this.

Please try reinstall CIS by following the advice I give in this post. Then, while still in Safe Mode, also check all folders inside the appdata (hidden by default) folder and make sure that all remnants of CCE are removed as well. Then reboot to normal mode and reinstall CIS like normal. Then check if CCE still has the same problem. If it does then this should be reproducible, and is therefore worthy of being forwarded to the devs.

I realize you probably do not relish the idea of reinstalling CIS, but it is the only way I can think of to ensure that there isn’t some sort of unintended interference which is causing this.

Thank you.

Thanks for getting back to me,

Yeah I sure will uninstall CIS 7.0.312140.4101 on my Laptop, and do a fresh install of it.

A fresh install may do the trick, since CIS 7.0.312140.4101 was an auto update from CIS 7.0.308911.4080.

However the Version of CIS 7.0.312140.4101 does have Diagnostic errors. I have uploaded a CISdump of that within this post > https://forums.comodo.com/format-verified-issue-reports-beta-corner-cis/good-files-detected-in-log-not-updated-after-running-rating-scan-v7bm888-t102197.0.html

However Before I do an Uninstall do you want me to try Killswitch and the same things using CIS 6.3.302093.2976 and see how it compares. Since I still have CIS 6.3.302093.2976 Installed on my Main Machine ?

Let me know Please

Thanks

Nige

Thank you.

Sure. If you don’t mind, that may provide us with important information.

Thanks again.

Hi again,

Well I tried Killswitch using CIS 6.3.302093.2976.

However I did the same test as I did with CIS 7.0.312140.4101 and unfortunately I came up the same result.

Like shown on Capture 1 right though to Capture 5.

So I have no idea what to try next.

So it is over to you Chiron or whoever else.

Nige

Okay, please edit your first post so that it is in the format provided here:
https://forums.comodo.com/bug-reports-beta-corner-cis/required-beta-bug-reporting-format-t101349.0.html

Also, please attach a diagnostic report and a KillSwitch Process List to your first post.

Thank you.

Done, 1st Post has been edited.

Thanks Chiron

Thank you very much for your report in standard format, with all information supplied. The care you have taken is much appreciated by Comodo, and will increase the likelihood that this bug can be fixed.

Developers may or may not communicate with you in the forum or by PM/IM, depending on time availability and need. Because you have supplied complete information they may be able to replicate and fix the bug without doing so.

Many thanks again.

As this was not fixed during the Beta testing period I will move this bug report to the main Bug Reporting Board.

Please check and see if this is fixed with the newest version (7.0.313494.4115)? Please let us know whether it is fixed or you are still experiencing the problem.

Thank you.

PM sent.

Nige_39 has informed me via PM that this is fixed for their main machine. I will therefore close this entry in the tracker and move this report to Resolved. Nige_39, if you find that this is not fixed for your laptop, or the problem returns, please reply to this report and send me a PM, with a link to the report.

Thank you.

I sent report in PM,

That it has stopped working for Main Machine, today , also it does not work with Laptop.

So it’s showing the same information as report in first post, but now I’m on 7.0.313494.4115 .

Thank you for checking this.
I have re-opened this in the tracker and will move this report back to format verified.

Thanks again.

No Problem, Lets hope it gets fixed!

The OP has informed me via PM that this is not fixed with CIS version 7.0.315459.4132. I have therefore updated the tracker.

The OP has informed me via PM that this is not fixed with CIS version 7.0.317799.4142. I have therefore updated the tracker.

Lets Hope, this gets picked up by the Developers this time :slight_smile:

Sadly, there are a lot of other bugs reported, and I have no information about the order in which they will be fixed in. I’m sorry that I cannot provide more detailed information, but truthfully I don’t know.

Thanks.

I have been informed that some processes will not be able to create a Full Dump. I was not aware of that previously. Please let me know if there are any processes which do consistently work on your system?

Also, can you please export your current configuration and attach it to your first post?

Please let me know when you have checked this, or if you have any questions.

Thank you.

Nige_39, is it possible for Full Dumps to made for processes which are not related to the OS or the CIS?

PM sent as well.

Hi Chiron,

I ran a Full Dump on Opera.exe and it worked fine

If I run a Full Dump on services.exe I.E. OS it does not work.

So I guess that is a fix

Nigel