Keylogger test failed

I’ve found a new keylogger test and Comodo fails protecting me against it even though it prompts about it and I choose block. :frowning:

I have attached it. Can you take a look ?

[attachment deleted by admin]

As I don’t use the CAVS, I wouldn’t know if it is in the database or not. But please send a ticket to the support. Submitting a ticket can be done here



This a keylogger test. And I was talking about Comodo firewall, not CAVS. :wink:

Oeps (:SHY),

Still you could submit a ticket or just ad it to the file submission. (:TNG)


By the way,

Which version of the firewall do you have + which status are you using (learning?)

I’m using version in Train with Safe Mode.
I receive the warning that the program tries to acces and record my keyboard, I choose Block but it fails.

COMODO fails to block this from successfully logging keystrokes. I’ve attached a screenshot of the four “blocks” that COMODO fails to succeed in blocking.

[attachment deleted by admin]

I don’t want to seem too impatiently, but I think this is a bug, to prompt and not to block the keylogger and I hope a Comodo dev will take a look. :slight_smile:

Did you post it to Bug Reports?

Also, open a ticket and cover your bases :slight_smile:

Actually, Comodo should come up with a better method of bug tracking. I’ve noticed that a lot of bugs mentioned in the forums sometimes slip through the cracks. If you don’t YELL now and then, they most likely will not be fixed. I would be very curious if Comodo even assigns bug tracking numbers to incidents reported in the forums or even for tickets that are opened. It is a very strange system when every time you open a ticket, that it comes back as closed. I’m told that is the way the system works, but it sounds half-baked to me. I have 2 tickets open.One has been fixed, but I never heard from support about it being fixed. I really don’t feel that it should be up to me to track a bug that I’ve reported. The bug tracking system should be doing that if there is one.


I tried the keylogger test, but it seems like the application you posted is corrupt. After allowing cmd.exe to run the keylogtest.exe, I get an application error. where did you get this file from?


[attachment deleted by admin]

it is not corrupted at all… for me it is working very well. It has been posted on PCTools firewall forum.

Can you do an MD5SUM on the exe and post here?

Thanks, Al

this leaktest needs .NET Framework to be installed! As for the “bug”… It clearly seems to be rather critical one (the FW is vulnerable to keyloggers!). I don’t have time right now but if anyone wants you can do the following - go to D+ → Image Execution Control Settings and set it to aggressive AND add an “All executables” file group to the list of files being checked (of course removing the default “*.exe” wildcard) and watch every DLL it loads and “block one allow every other” until you find one that causes keylogger to work as it expected. Since it’s .NET - maybe it’s the system who performs keylogging, not the app itself.

Ugh, this piece of cr*p needs dotNet to run. That is why it will not run for me. I don’t have NetFrame installed and will avoid doing that as long as I can. ;D


Vista has it preinstalled, so… no real chance of avoiding it :-))))

personally i didn’t see any trojans written in .NET languages since the majority still doesn’t have it installed… maybe they will become widespread with Vista…

The new 3.0.14 beta passes this test. Tried in my virtual machine and the keylogger could not pickup anything. Congrats Comodo.

Yes, congratulations now. The keylogger is now succesfully blocked. :BNC
The window remains like this(see attachment) and no key is intercepted. Good work guys. (:WIN)

[attachment deleted by admin]