Keyboard lockout following CIS installation

Hardware. New Lenovo Ideapad Z585 AMD A8-4500M APU with Radeon HD Graphics 1.9 Ghz Ram 8.00GB
OS. Factory installed Windows 8
Installed CIS 6.3.39106.2972
Worked ok for a few mins but when Lenovo-9941.vbs and Lenovo_hid.sys were detected the keyboard/touchpad locked up.
Installed a virtual keyboard which worked ok.
regardless whether these items were blocked or given full permission keyboard remained locked up until CIS uninstalled.
Same issue also encountered with Trusteer Rapport which was much more difficult to remove.
Problem continued to occur under mcafee internet security following the install/uninstall of CIS. Issue did not appear beforehand.
The machine was upgraded to windows 8.1 but problems still occurring.
Ran a full factory image restore, leaving at windows 8. Mcafee running fine.
Are there any known compatibility problems with Lenovo hardware?

Originally CIS was working fine on a Lenovo Ideapad Z570 windows 7 intel core i5 until this packed in after 2 years with a motherboard error. We also ran the CIS / Trusteer combo on a replacement Toshiba satellite core i3 windows 8.1 without any problems until the toshba packed up with a battery charge error. We had this replaced with the new Lenovo but have not successfully run the CIS or Trusteer software on this machine. It would appear to be a hardware compatibility issue.

We may try again once we have windows 8 upgraded to 8.1.

Are Lenovo-9941.vbs and Lenovo_hid.sys on the Unrecognised Files list? If so move them to the Trusted Files list and reboot.

Keep us posted.