keeps prompting over and over again

I like the new firewall. Very cool. Unfortunately, when I give a program permission, I don’t want to keep doing it over and over and over again. For instance I had Second Life installed on this laptop. It’s a virtual world, but doesn’t do well on the laptop. I chose to uninstall it. Upon trying to uninstall, the Comodo firewall started prompting me for permission for the uninstall program, and it kept prompting me again and again, as the uninstall program deleted files. I think it was accessing sub directories within parent directories, therefore making permission slightly different each time. The only thing I can do is place the firewall back into learning mode, which is an option given on the permission dialog. After awhile the firewall asks if I want to stop using learning mode and go back to normal mode, at which time I say yes, since I’m done doing what I’m doing. Anyway, following the first prompt for a program, it should not prompt again for that program. If you can’t figure out how to do that progamatically, please put a new option in the configuration that says, “ONE TIME PROMPTING”. Thanks

I reported this problem from use of the Comodo firewall on a laptop, and I was out of town. Upon returning home I proceded to install the new firewall on my main desktop PC. The Comodo firewall install went OK. Then I installed Comodo BoClean, the anti malware software. I had to tell the firewall this was OK, thirty or so times. The firewall kept prompting me over and over again for the same EXE file. I think the EXE was doing something a little different each time. I don’t know. I don’t remember if verbiage in the message was the same or repeating. This is ridiculous. If I say the EXE file is OK one time, I should not have to say it again. I have approved it! So what if it does something a little different and needs different permission? I already said it is OK!

Please make this change. After saying an EXE file is OK, then it is OK for everything!

I ran one of my regular backup processes. A folder on drive C: containing a lot of subfolders is copying to drive D:, but first the whole thing is deleted from D:. So what does the firewall do? It prompts me for every single folder being deleted. To make it quit I had to place it in learning mode, which is an option on the dialog. Does that mean the firewall is recording each folder name as the backup program runs? Tooooooo much stuff! The firewall doesn’t need to be saving all that information. I wrote the backup process and use it for many different things. Am I going to be prompted each time I backup a different folder? I need to turn off this defense thing until you make the functionality more realistic.

Try to use “Treat As” Truste Application instead of just allowing each time. It will save you time.

MY KEEPS REPEATING AS WELL!! I am running AVG ANTIVIRUS and it won’t let it update and I get the same pop up message and I click allow and remember the answer and still the same thing…SOMETHING NEEDS TO BE DONE ABOUT THIS!! users need to be able to get their antivirus updates!!

Does anything show up in the logs as being blocked when the update is occuring?


no…I just keep getting the pop ups and nothing is recorded anywhere…I don’t know how many times I have told it my antivirus is a trusted program…But I still get the same message and it still blocks my updates…javascript:void(0);

Something needs to be done about this v3…I can’t even turn my computer off anymore…I won’t let me run any updates on my antivirus nor will it allow it to scan for viruses!! What kind of protection is that? This thing doesn’t remember any of the settings I have asked it to remember!! Bring back v2…

I will not be recommending this software to any of my friends like I have in the past…Bring out an update a.s.a.p. or you will loose a long time supporter of your software… (:AGY) >:( >:( >:(

I have been getting the same problem, also I’ve noticed under “Network Security Policy - Application Rules” the same .exe is listed numerous times for each application. Same thing in “D+” under “Computer Security Policy”, I’ve included some screen shots below (AVG seems to have more problems than most other apps for some reason).

[attachment deleted by admin]

I agree “treat as trusted” works much better. I AM NOT GOING TO READ A USER MANUAL TO SEE HOW THINGS ARE SUPPOSED TO WORK. I don’t have the time nor the attention span. If functionality is not obvious on the screen I will not see it and will not use it.

I uninstalled the firewall and reinstalled, so all histories would be gone. I want to use the “treat as trusted” option since that will create less internal data structures.

I have to click too many times to choose “treat as trusted”. There is the third radio button I must click to enable the dropdown, there there is the dropdown after that. The dropdown initially says “enter learn mode” or something like that. It should already have “treat as trusted”.

we have identified the bug and fixed it, should have an update next week.

Very odd I have AVG Antivirus 7.5 no problems with scans and updates (Major updates included) with CPF3 and have been testing since the second alpha the only problem is the short path problem (~1).