KAV refuses communication - gets blocked.

Hi,

I have Kaspersky Anti Virus but it cant get updates with CFP running. The problems start immediately on boot up. I get a message from CFP that kavsvc.exe is trying to act as a server. In the “Security Considerations” dialogue it says “kavsvc.exe refuses communication with COMODO Firewall Pro.”

I can click Allow, but there is no check box for it to remember this decision. I therefore have to click Allow about 50 times while KAV is updating.

In Application Monitor I have checked the boxes for allowing invisible connection and also for disabling the advanced checks. I also turned off Behavior Analysis altogether and still the same problems. And kavsvc.exe with parent “services.exe” is allowed in/out TCP and UDP to or from any IP. Ive tried turning the parent check off too.

In the Network Monitor I have the default rules that that CFP installs. I have added a rule to allow all TCP and UDP, both in and out, to and from any IP address, to or from any port, and moved it to the top.

Still every single time I try to update KAV I get a message asking to allow or deny. As soon as I allow all, it is fine.

Dont know if its relevant but I am on an ICS client. Host is 192.168.0.1, my client is 192.168.0.3. I have added 192.168.0.1-3 as a trusted network. Also added a rule allowing UDP to/from 192.168.0.255 and 239.255.255.250 for my trusted zone. (Something to allow the client to control the net connection I think.) Everything seems to be running fine with ICS. Just this one problem with KAV.

Can anybody help?

I just turned off Application monitor (which auto switches off Component Monitor and Behaviour Analysis), and it worked. Network Monitor is still on, so it is definitely not that. If I switch off everything but Application Monitor it does not work. Only when I switch off Application Monitor does it start working.

Here is the type of message I get when Windows starts:

http://img155.imageshack.us/img155/16/kavbootupma1.jpg

This is the type I get when trying to update KAV:

http://img155.imageshack.us/img155/1019/kavrefusescommck9.jpg

Here is the rule in Application Monitor:

http://img155.imageshack.us/img155/191/apprulemy6.jpg

same problem here… is there a solution to this problem? (:SAD)

The antivirus from Kaspersky (It’s a good one :P) doesn’t cooperate with comodo yet
I think they’ve got the same problem here https://forums.comodo.com/index.php/topic,6406.0/topicseen.html
So don’t worry, it’s not a virus, you just need to go trough all the annoying pop-ups :SMLR.

Hope I could help you
Xan

Sool, so sorry your topic seemed to get ignored. Anyway, welcome to both Sool & fybz on the forums.

Thanks Xan, you are quite right. Here’s what I said in the other topic…

I'm afraid not. It seems that Kaspersky AV might be incompatible with CFP, but we've not had the official word from either Comodo or Kaspersky. Mainly based on forums feedback here, it seems that some versions of KAVs refuse to install now when CFP is present & require that CFP is removed first. So, I'd guess that Kaspersky know something.. but, they're not saying anything publicly that I've heard. Several CFP users have reported problems with KAV/KIS (KIS is understandable, since it has a firewall component) & whilst I've encouraged them to report these problems to both Comodo & Kaspersky (hoping for some official comment), nothing has been posted as yet.

So… you can go to Comodo Support, register on their system & raise a ticket on this issue. I’d also encourage you to do the same with Kaspersky & raise this issue with them. I’d be very grateful for any feedback that anybody can provide, thanks.

In addition, I’ve asked Comodo for the status of the issue. Once I have it, I’ll post it to the forums.