Kaspersky Antivirus 5.0.376 [RESOLVED]

I am having trouble getting CPF to allow kaspersky to auto update.

I have tried adding kav.exe into the list of allowed applications, but i still cannot get it to connect to the update server. when i set CPF to Allow All, the connection is established.

how do i set CPF to allow kaspersky to connect?


If you open Comodo and go to application monitor >> right click on Kaspersky >> select edit >> choose allow all activities for this application >> select OK

Hope this works,


Addition to Mike’s solution,
You can also set invisible connection right with following steps:

1- Security->Application Monitor,
2- Double click on one of the Kaspersky rules(any of them), Go to “Miscellaneous” tab
3- Select “Allow invisible connection attempts” checkbox

thanks for the quick replies.

unfortunately, none of them have cured it.

the only way i can get it to update is to close CPF, set it to “Allow all” or to disable app monitoring.

ive tried allowing all the kav .exes access (kav.exe, kvsvc.exe and kavsend.exe) but the problem persists.

any further ideas?

I had the same problem when I trialed kaspersky.No matter what it would not prompt comodo for permission to access.Of course if allow all it would update. Maybe check with kaspersky’s forum.I gave up on it.

Can you retry by disabling the basic popup logic options?

Try to disable Security->Advanced->“Basic Popup Logic” check box and reconnect to see if CPF produces prompts.

Disabling the pop up logic makes no difference, i dont get any alert pop ups saying kaspersky is trying to access the update servers.

Just as an update to this topic, we have found the problem about KAV connection blocking. CPF is automatically blocking the KAV’s internet request because of its internal risk calculations and does not raise a popup. We have addressed the issue and fixed.
This fix along with many others will be available with the update which is planned by the end of april, 2006.

Thank you for your feedback!

That’s good to know.Thanks egemen

Thanks for the update.

Thanks for the info. ;D

Good to hear of another update :wink:

Thanks. good to know its going to be cured. ;D