Just want incremental backup over NAS (year two)

I purchased a 1TB NAS black box harddrive possibly a year ago now, and from day one the prospect of backing up anything has been a nightmare. No fault of the NAS box, it seems great. It’s just there doesn’t seem to be a single functional software solution available. I’ve downloaded trials for several commercial products that just fall flat on their face…

Microsoft’s builtin service was a bust from square one. Maybe because I’d recently upgraded Vista to 7 but the general consensus seems to be it’s garbage, don’t bother.

COMODO was universally praised, but the version of the software everyone agreed was good seemed to be gone from the scene. The new software could not do incremental backup…

So I followed these forums for what seems like months waiting for the long promised incremental feature. Now it’s said to be available in the latest BETA download, so I immediately installed that.

Now here I am, and the NAS feature in the latest BETA is just not working. Exits code(1) first message after taking off. I don’t understand why NAS is a problem at all. Seems like it would be completely transparent file system wise.

There is no dialog for feeding a username/password for the Windows share to CB. I suspect that’s the problem. The only passcodes that worked before were Everyone and an empty password.

The folder I setup for backup is wide open access wise. The only thing I have not tried is making the folder only available to an account with the same passcodes as the account doing the backing up, but I am really not comfortable sending my local passcodes out on the network/internet.

PS: For CB developers, after closing CB. I had to kill the CBU.exe process before it would start again. Maybe because last time I ran it “as administrator” because another NAS related thread suggested UAC could be a prob. Now it always wants to start “as administrator” and the “run as admin” box is not checked in the shortcut’s properties.


Please update to the latest version.

If the problem still exists please follow these steps to help us determine the cause of the issue:

  1. Go to Windows → Run type "cmd.exe’ and hit Enter
  2. In cmd.exe window type “C:\Program Files\Comodo\Comodo BackUp\CBU.exe” /enabledebug
  3. Restart CBU.exe
  4. Repeat the incremental backup process
  5. In cmd.exe window type “C:\Program Files\Comodo\Comodo BackUp\CBU.exe” /dumpdebugcontent
  6. Collect the “Debug.cbu” file located in the “C:\Program Files\Comodo\Comodo BackUp” folder and post it here for analysis.


0% An error occurred during the backup process...

Error Occurred: Could not retrieve disk information.
X Backup process failed with code 1

PS: You guys really should allow .cbu attachments / write debug.cbu to a user folder / without restricitons >:-D

[attachment deleted by admin]


Please try to perform a full backup an then increment based on that. A new incremental backup would have been the same thing anyway. Let us know.


Edit: I assume you selected the incremental and “make new backup” option and didn’t have any previous backups of the disk?

This has been done.

Still intend to follow up on this, but CB had wanted to update itself, which it did, and then wanted a restart… which is something I do maybe twice a month.

I’m curious in the meantime if anyone has had success with incremental/NAS/Windows7.

PS: I also want to say as long as someone is listening to my suggestions. A full backup to NAS over lan can easily take 48hrs or more. The last time I did a full backup I’m pretty sure there was no software (including Comodo and Microsoft) which would do a pause / resume… further more I’m almost certain putting the computer to sleep would break the backups.

Seems like a no-brainer any backup software should go into low power state gracefully and even recover from power down/loss… and keep a low priority unless things are slow.


When I choose the Icremental Option is seems to work doing a backup. The problems occurs when the backup is made again, comodo going through all the files again and it takes exactly as long time as the first time. Is this a general bug in the software? I’ve been trying to solve this problem for maaany hours now and I start realize that the function doesn’t work over FTP?!


Are you using simple copy backup or cbu file backup?
Is it files and directories backup?



Thanks for quick response. I’m doing the cbu file backup, and yes it is files and directories.


Is this issue still present when running the backup for the 3rd time?



Yes. I choose the Incremental from the start, uploading, say five files, If I thereafter add a new file it still uploading all the previous files once again. Is this feuture not present with the cbu format? Why do I need to do the backup 3 times?

I dont have the bandwidth to do a complete backup every time so I really need the Incremental backup to work.

Another question: When I want to edit the saved profiled backup all the preconfigured data are erased, so I need to enter them again, am I doing something wrong here? Can I load the profile from somewhere?


I’ve just read in another post that the incremental backup works with simple copy? I might consider doing simple copy instead of trying to get the cbu backup to work… Anyone had any success with this?


CBU incremental file backup still needs some optimizations, that is why you need to run the backup twice then you will observe a difference in backup speed.
You can use incremental simple copy, it works successfully, it is based on file sizes / date last modified and on second run you will see the difference.


Okey I’ve done this now, still doesn’t see any difference except that if I make changes to my files it actually works with the incremental. But when I press the backup (in my custom profile) the backup still processes all the files I have in my folder, is this what it supposed to do? I would prefer the software to only process the files that have been changed since the last backup. Say that I have an outlookfile which is really huge, I don’t want the software to process that entire file every time it runs the backup.

When I want to edit my customized profile, the alternatives I’ve choosed before are all “erased”(?) since, e.g. the first step has changed the backupformat to “sync copy” and scheduleformats etc all all gone, and I need to relogin to the FTP-site every time I want to make a change to my profile. Etc etc, it seems that it doesn’t save my profile, but the schedulefunction is working, I believe.

Doesn’t the software have to have a checking-mechanism against my FTP to compare the different file structures before making the backup? Like, all the backup files at the FTP has these “dates-last-modified” and compared to the files at my workstation, these files need to be updated?

Thank you


All files are being processed because they are checked to for changes based on date modified or file size.
This doesn’t mean the files will be copied again to destination.

There are some issues with editing custom profiles / schedules.
They will be fixed in a later update.

Yes it does.
It checks for date last modified and file size and it doesn’t upload a file if these haven’t changed.


I am doing a new full backup over the same NAS which reported error for incremental.

It’s estimating about 7hrs for a 200GB backup. I hope that is accurate. If so I will let it finish.

The incremental option should not require going thru the full backup process once. It has a “full backup” sub-option, which seems like it should do a first time backup if selected.

I’m assuming I can incremental over the full after it’s finished / setup a schedule. There doesn’t seem to be an option to pause or repair the backup. I’d like to know if I can put the computer to sleep/hibernate or not if anyone can say before it’s finished (if I don’t accidentally put it down / find out that way first)

Personally I would much prefer CB to live in the taskbar tray / perform partial incremental updates sporadically versus being on a schedule or require prompting. I never know when the computer will be on so a date/time based schedule is pretty useless. Though a schedule based on hours logged might not be bad. Still sporadic would be better (with a priority on regularly changing files) because hours logged might not reflect work done.

The backup crapped out at 18%. Probably because I found the computer in standby mode. I might’ve done that on accident, or it might’ve ended up that way after I put it in power saver mode; even though I’d made a point to change the standby settings for that mode to never.

Speaking as a software developer a computer going into standby has never even required writing a lick of additional code. I just don’t understand why backup applications running for hours can’t survive a standby. Even accessing files on the Microsoft network is a totally transparent deal 88)

I’m just so frustrated with backup technology if I didn’t have better things to do I’d write my own ■■■■ backup software. And here I thought I was being ridiculous being paranoid about the computer going into standby (but my memories of losing a ton of electricity to one failed backup after another knew better)


I’m sure the the computer went into standby after the backup failed, then the stand-by prevention is disabled.
If you can reproduce the error please follow the steps here https://forums.comodo.com/news-announcements-feedback-cb/how-to-collect-debug-information-t63958.0.html so we can determine the exact cause of the issue.
As for schedule, I suggest you choose daily backup with option "“Run schedule as soon as possible if missed”.


I wondered at some point why there was not standby prevention like with so many apps I’ve used in the past. However I did for a fact put the computer into standby out of habit, but promptly brought it back up without the backup stopping. So if prevention was working it did not seem able to prevent a manual standby.

I know I can setup the power plan to ignore a manual standy attempt, but I dunno if that is the same deal.

I’m kind of at my wits end again / fed up with backup software.

The process should be more resilient. It’s ridiculous to leave a computer on all day for naught. And I have so little confidence in backup software, I’m just all but certain if I ever needed to do a restore it would not work :confused:

I would like a fully automated process that was reliable. But the only thing that seems to work or even be convenient is manually copying files.

If a backup can’t even finish, it’s hard to imagine it routinely performing maintenance on itself. I’m sure I’d have to be extra careful not to put the computer in standby without checking if the backup agent was performing it’s scheduled task first, and it would probably be more of a hassle than anything.