"Jump to Folder" is available with "Submit" & "Lookup" from "File List" [M2153]

User cannot jump to folder after submitting an unknown file.
Can you reproduce the problem & if so how reliably?
If you can, exact steps to reproduce. If not, exactly what you did & what happened:

  1. Go to File List

  2. Do not select any item > Right-click
    note: “Jump to Folder” action is NOT available

  3. Submit a file

  4. Do not select any item > Right-click
    note: “Jump to Folder” action is available

  5. Lookup a file

  6. Do not select any item > Right-click
    note: “Jump to Folder” action is available

One or two sentences explaining what actually happened:
“Jump to Folder” action is available to user in Lookup and Submit windows.

One or two sentences explaining what you expected to happen:
“Jump to Folder” should not be available to user if no item is selected.

If a software compatibility problem have you tried the advice to make programs work with CIS?:
Any software except CIS/OS involved? If so - name, & exact version:

Exact CIS version & configuration:, default configuration
Modules enabled & level. D+/HIPS, Autosandbox/BBlocker, Firewall, & AV:
Have you made any other changes to the default config? (egs here.):
Have you updated (without uninstall) from CIS 5, 6 or 7?:
if so, have you tried a a a clean reinstall - if not please do?:
Have you imported a config from a previous version of CIS:
if so, have you tried a standard config - if not please do:
OS version, SP, 32/64 bit, UAC setting, account type, V.Machine used:
Windows 10 Pro 1607 64-bit, UAC on, Administrator account.
Other security/s’box software a) currently installed b) installed since OS, including initial trial security software included with system:
a=n/a b=n/a

Please create a video.

No. I’m not making a video. The bug is easily reproducible by following the steps.

I tried your steps & did not see a problem. I probably misread your issue. I’ll check again tomorrow.


Checked again and there’s no problem on my system. In general, you have to select the item (eg with a left-click)-> you cannot perform a direct right-click → and that’s why you get that message.

If we cannot perform a right click, then the context menu for “jump to folder” shouldn’t even exist. Or else add it. In my mind, this is clearly a GUI bug.

Anyway, here’s the video.

[attachment deleted by admin]

It’s by design. The problem, now that you mention it, could be that mentioned action is available to user (it shouldn’t be unless you select an item). I’ll report that one.


Thank you very much for your report in standard format, with all information supplied. The care you have taken is much appreciated by Comodo, and will increase the likelihood that this bug can be fixed.

Developers may or may not communicate with you in the forum or by PM/IM, depending on time availability and need. Because you have supplied complete information they may be able to replicate and fix the bug without doing so.

Many thanks again.

Not sure why the title was edited incorrectly. Jumping to folder is not available when right clicking after lookup or submit.

Moving to resolved as this should be fixed with Comodo Internet Security v10.0.1.6209. If you still experience this issue please make a reply or PM a board moderator thanks.