Jump to Folder from Rating Scan always opens System32 folder

Jump to folder
Can you reproduce the problem & if so how reliably?:
After performing a rating scan from within Comodo Internet Security, when a user right clicks on any of the files in the results window, an explorer window opens up pointing to system32.
If you can, exact steps to reproduce. If not, exactly what you did & what happened:
1:Open Comodo Internet Security
2:Click on Tasks, choose Scan
3:When the scan is finished, right click on any file in the results window and choose Jump to Folder
One or two sentences explaining what actually happened:
A Window opens up to System32
One or two sentences explaining what you expected to happen:
I expected a window to open up to the directory where the file resides.
If a software compatibility problem have you tried the advice to make programs work with CIS?:
?
Any software except CIS/OS involved? If so - name, & exact version:
No.
Any other information, eg your guess at the cause, how you tried to fix it etc:
Programming error

B. YOUR SETUP
Exact CIS version & configuration:
10.0.1.6209, Firewall Security
Modules enabled & level. D+/HIPS, Autosandbox/BBlocker, Firewall, & AV:
D+/HIPS disabled Auto containment enabled, Firewall on safe mode, AV not installed.
Have you made any other changes to the default config? (egs here.):
Block and log dropped packets, block unknown apps instead of sandbox.
Have you updated (without uninstall) from CIS 5, 6 or 7?:
No
if so, have you tried a a a clean reinstall - if not please do?:
?
Have you imported a config from a previous version of CIS:
No
if so, have you tried a standard config - if not please do:
?
OS version, SP, 32/64 bit, UAC setting, account type, V.Machine used:
windows 10 Professional 1607 build 14393.969
Other security/s’box software a) currently installed b) installed since OS, including initial trial security software included with system:
a=Avira Free b=?

just need you to attach your config and run the diagnostic report and attach the zip folder it creates thanks.

Actually it was a mistake on my part. When you left click on an entry to highlight it, and then right click anywhere else, it still jumps to the folder of the item that is highlighted instead of the one that you right click.