Jobs scheduled as service run fail to execute


Some tech specs first.

  • Comodo Backup version: 3.0.171317.130
  • OS: Windows 2003 SP2 32-bit
  • No AV/FW
  • No other backup software
  • User running the backup has Administrator access.

We scheduled a couple of full backup jobs as “Service run”. They worked for a couple of weeks and inexplicably stopped working! We’ve tried to reschedule the jobs but without success. Only by changing the Run Mode to “Silent run” did they finally start working again. Yes, we double-checked the scheduled task items to ensure the “Run only when user is logged in” setting is NOT checked.

The interesting thing is, the last job executed time was updated, except no backups were produced (the jobs appeared to have completed within a few seconds).

We’ve also noticed that the Manage Backups GUI is a bit bugged. The first time you try to schedule a backup, it says successful but there are no scheduled task items created. Only after opening and closing the GUI do new scheduled task items appear for the jobs. The jobs are also created with the setting “Run only when user is logged in” checked, which defeats the purpose of a service run doesn’t it?

Furthermore, the calendar was not being updated properly. One of the jobs that was failing to properly execute had the last executed timestamp on the correct scheduled date, but the job was appearing on March on the calendar, with the time to execute saying “2 days from now”.

So to summarize, our issues are:

  1. Scheduled jobs in Run Mode of “Service run” failing to execute
  2. Manage Backups GUI not refreshing correctly
  3. Scheduled task items not being created at all, and not with the proper settings


For issue, number one, please recreate the schedule jobs and enable logging to file in backup step 4.
Then, check the log after the backup is supposed to run.
Issues 2 and 3 will be fixed with next release.