Java Web Start Splash:recv failed


Comodo Firewall is preventing me from running the ADDS - Flight Path Tool (found The program requires Java to be installed from The error message received when running the Flight Path Tool is “Splash: recv failed”.

The only way to get it to work is uninstall Comodo Firewall.

System Info:

Vista x64 Ultimate
Java version JRE 1.6.0_06
Firefox 3.0/Mozilla 5.0
All the latest OS patches/updates/LAN drivers

I have defined all the Java Programs as trusted applications. Set the programs to run as administrator. Tried the compatibility mode for XP SP2. I tried using IE7, installing a desktop shortcut that links directly to the program. Went into the Java Control Panel and changed the network settings to connect directly.

When the program attempts to connect, it tries to connect to Remote - TCP, Port 51258.

I did succeed at running the program once somehow with Comodo Firewall installed but I closed it immediately and was unable to open it again. I kept getting the Splash: rec failed error.

If one of you would be so kind and see if you encounter the same error message and possibly help me out I would appreciate it.

Hello as2008 and welcome to the forums :slight_smile:

I assume your talking about downloading;

Follow the link below or type the URL into the Java Web Start “Location” field:

I received the “Rec Failed” as well, Put defense+ in learning mode. then it will work for you :slight_smile: then switch back to safe mode after you’ve done what you need to do… Running it again shouldn’t need to switch :slight_smile:

Hi Kyle,

First, thanks for your help. Yes you are correct, is the correct URL.

After a bit more troubleshooting I solved the problem. Here’s how:

  1. Create a desktop shortcut for the javaws.exe located in the jre1.6.0_06 directly where your java is installed. In my case it is E:\Program Files (x86)\Java\jre1.6.0_06\bin.

  2. Right click on new shortcut icon. Scroll to properties click

  3. In target box paste
    E:\Program Files (x86)\Java\jre1.6.0_06\bin\javaws.exe “-Xnosplash” “

This allows the program to open without using the splash screen. Hope this helps.

I’ve had this problem with an application. I still have it actually. The splash screen will load either the first time or after some tries if it ever comes to that, but the problem isn’t 100% gone. Then again it’s not 100% there, so I’m happy with that ^^

Is there some form of leak error in Comodo that prevents it from blocking my safe program from sneaking through? Consistency requires that it blocks whatever it is that it’s blocking, even if I don’t want it blocked, at least 24/7 ;D

Ah, and of course the program worked for years during Comodo’s stay, so I really doubt it’s the problem. Just joking a bit. I just wanted to toss in my input that I’ve experienced this problem and don’t attribute it to Comodo :stuck_out_tongue:

This may very well be a bug, I tried again and it didn’t work, It seems to work some times and not others.

Hello All,
I have the same problem. Comodo Firewall is sometimes preventing me from running my Java… I tried to change many setting but with no success.

Any Idea?

Thanks in advance


maybe you can try to add “javaws” to “My Trusted Software Vendors” in the Defense+ menu. Just add the javaws file, which is stored in “C:\Program Files\Java\jre6\bin” (maybe different on your PC), to the trusted vendors. This worked fine for me.