Java (tm) Plug-In 2 SSV Helper scanner hang [M426][v6]

A. THE BUG/ISSUE (Varies from issue to issue)
[ol]- Summary - Give a clear summary in the topic subject, NOT here.

  • Can U reproduce the problem & if so how reliably?:
    Yep, every time.
  • If U can, exact steps to reproduce. If not, exactly what U did & what happened:
    a: Start a Scan
    b: The scan will hang on Java ™ Plug-In 2 SSV Helper
  • If not obvious, what U expected to happen:
  • If a software compatibility problem have U tried the conflict FAQ?:
    There are no conflicting programs.
  • Any software except CIS/OS involved? If so - name, & exact version:
  • Any other information, eg your guess at the cause, how U tried to fix it etc:
    This was apparently fixed by the update released around July 16, 2013, but that release eventually caused strange issues whereby it said there were updates, but updating gave the same version. It also periodically failed on DB updates. I did a clean install, using removal tools and without importing any configuration, and then this issue returned. It is also still telling me there are new updates, which do not update anything.
  • Always attach - Diagnostics file, Watch Activity process list, dump if freeze/crash. (If complex - CIS logs & config, screenshots, video, zipped program - not m’ware)

Attached everything is in 1 zip.
A rar file is also attached which contains a screenshot of the full handles list of cavwp.exe and a mini dump.
Also, a Full cavwp.exe dump done during the freeze can be found on: MEGA

B. YOUR SETUP (Likely the same for each issue, so you can copy forward)
[ol]- Exact CIS version & configuration:
CIS 6.2.285401.2860 Virus Database: 16969

  • Modules enabled & level. D+/HIPS, Autosandbox/BBlocker, Firewall, & AV:
    Default Settings
  • Have U made any other changes to the default config? (egs here.):
    It doesn’t make a difference.
  • Have U updated (without uninstall) from a CIS 5?:
    [li]if so, have U tried a a clean reinstall - if not please do?:
    [/li]- Have U imported a config from a previous version of CIS:
    [li]if so, have U tried a standard config - if not please do:
    [/li]- OS version, SP, 32/64 bit, UAC setting, account type, V.Machine used:
    Win 7 Home Premium, SP1, 64 bit, UAC Off, Admin, Not a VM
  • Other security/s’box software a) currently installed b) installed since OS: a=Malwarebytes Anti-Malware full version (on demand scanner running, but uninstalling does not solve problem) b=no programs which have not been removed and then cleaned again with specialized removal tools

[attachment deleted by admin]

Very sorry you are having all these problems.

It’s actually very unlikely that the file the scanner seems to hang on is the one causing the problem, unfortunately. You can test this by doing a right click scan.

If it isn’t that one which is causing the problem, would you be kind enough to follow the procedure in the resources for bug reporters sticky to try and identify and append the culprit. (When you have you can simply add to scanner exclusions to resolve the problem).

Please also could you append your active process list, so we can see if you have any conflicting software etc etc.

Could you also answer both B.7 a and b please. Is MalwareBytes the esident or the on demand scanner version?

Best wishes


Hey Mouse1,

Everything is in the zip, a Screenshot, Crash.dmp, Killswitch.cvs and the CiS report/dumps.

I edited my post above to add 7.a and b, I missed those, sorry.

I could check if it’s the culprit but I reverted back already plus I have the same setup (programs (including MBAM running on the background)/OS/pretty much everything else you can think of) on my laptop which has no problem at all with the java helper, it’s really just the latest version so I assume 80% of the people running comodo have it on their computer since it’s a part of the basic java pack.

The moment I reverted back to the old version it just started scanning again without any hangs, I tried installing it again and tada it hung again.
I do remember finding a related topic on here but I have no idea where it was, I do know that the solution did not fix it for me.

It really sucks, I want to switch to the new release haha.

Can you please update to the newest version and go through the process to determine which file the scan hangs on?

The problem is that if the scanner actually hangs on a different file than that which it appears to, then the devs cannot fix the bug. In fact, this would have led them down the wrong road. Thus, I do not think we can forward this to them without first ensuring which file the AV scan hangs on.

Please check once again which file the scan hangs on, by following the advice given by mouse1, and let us know. Also, please leave the new version installed until we forward this to the format verified section. It’s possible that there may also be other information which we will require.

Thank you very much, and I hope you understand the situation. We are trying to make sure the bug reports are handled in such a way that they help improve the product, and help users like yourself, to the greatest extent possible.

sigh I guess I’ll install it again later on then…

How does one exclude Java ™ Plug-In 2 SSV Helper though because I have no idea where it’s located.

I’ll leave it installed afterwards, I had alot of problems forwarding utorrent aswell though, is there a v6 topic for that because my previous firewall rules (which I just copied) don’t seem to work plus it has a serious hard time adopting http/https rules shrugs.

This page should help to identify the file it hangs on.

Also, after re-installing the new version be sure to not import any of your old rules directly into it. Sometimes the older rules, especially going from V5 to V6 cause problems.

Alright I de-installed Comodo v5 with Revo again and thoroughly cleaned it afterwards. Rebooted. Ran the Comodo tool. Rebooted. Ran the Comodo tool again as normal admin (can’t hurt). Ran WinASO Registry Cleaner, WISE Registry Cleaner and CCleaners Registry Cleaner. Installed v6 and left everything to standard mode. The Scanner started running again and it hung on java helper again.

I manually scanned the System32 and the content of the other 2 dirs (see Screenshot or dump) no problems at all. I couldn’t manually scan the \Device\KsecDD dir because it’s most likely loaded from the registry.

I made a Screenshot of the full handles list of cavwp.exe and a mini dump. I have a full dump aswell but that’s alot larger ofcourse and I made it with Process Hacker instead of Killswitch because Killswitch hung on the big dump file, the small dump file I included is from Killswitch (not that it matters).

I hope this is enough for you guys to go on :slight_smile:

[attachment deleted by admin]

Thank you very much for your report in standard format, with all information supplied. The care you have taken is much appreciated by Comodo, and will increase the likelihood that this bug can be fixed.

Developers may or may not communicate with you in the forum or by PM/IM, depending on time availability and need. Because you have supplied complete information they may be able to replicate and fix the bug without doing so.

Many thanks again

No problem, i’ll await further instructions then :P.

Btw, I added another sceenshot showing the “hang” running for 1 day and 14 hours since the last one was a bit short (18 min or something) so it’s not really useful, it’s just extra confirmation.

[attachment deleted by admin]

Please feel free to add any additional information you find. All it can do is help.

Can you please check and see if this is fixed with the newest version (6.2.282872.2847)? Please let us know whether it is fixed or you are still experiencing the problem.

Thank you.

PM sent.

Problem is still there, just rebooted and tried to let it do the initial scan again but it still hangs on Java ™ Plug-In 2 SSV Helper.

I had same problem 2 months ago and tried everything to solve this but I had nothing. I deleted java plug-ın2 ssv helper then I scanned and scan hanged on another file(I cant remember now). I am re-install all system and the first job I did set up Comodo. and problem was solved. I have no problem now. Comodo and its scan running with no problem
I just want to say this dont know its usefull or not.

btw rating scan did not run, too . Full scan ran with no problem.
quick and rating scan did not run on these days.

[at] Saintj, thanks for checking. I have updated the tracker.

Also, if you don’t mind, please try reinstalling by following the advice I give in this post and see if that solves the hang.

this post could not solve the problem when I had this problem. do not work this post :-TD

It may help with some computers, but not others. I think it’s worth trying, unless a lot of rules were created and it would be a hassle to create them all again.

of course ıts worth to try . but I think there was something on background about this problem

Yeah that’s kind of the way I always install my major comodo updates (v4 to 5 or 5 to 6, you get the point), I’ll give it a try though, it’s not like it’ll hurt but I really doubt it’ll help.

I pretty much try to keep my registry clean and everything in optimal state (comps on 24/7 so might as well run maintenace stuff at night), I’ll report back if it changed anything though.

I seriously don’t get where this bug is comming from since i’ve got exactly the same setup on my laptop, the only difference is that this is a media center and my laptop is used for audio creation/DJ-ing etc. but all the core programs aswell as the OS are exactly the same yet there are no problems on my laptop what so ever shrugs.

Thanks for adding what happened with your setup btw YİGİDO_58, a fresh install of windows will most likely solve it but I seriously don’t feel like backing up multiple terabyte of data and reinstalling everything again, seriously hate doing that :P.
I think I saw a couple of other posts of people with similar problems in CIS v3 (i think) so it looks like java helper doesn’t like Comodo or something.

I saw this problem one of my friend user of comodo.
and maybe time to buy a external memory :smiley: send all data into it…then re-install all system…solve your problem…and say hello to yoour fresh system…faster than the old times…just like the first day of your computer ;D if you will do that you never regret it :-TU
but after reinstalling the system, the first job is install a clear CİS look at the Chiron’s topic