Java Heap issue still in 3.9

This is a great product but I have an incompatibility with one application which won’t operate with Comodo installed.

Comodo Version 3.9.95478.509

Borland JBuilder 2005 (Java based) complains about can’t start Java VM because of heap space problems and then quits.

Problem is on a Windows XP SP3 system 1.5G memory.

I have tried all the remedies I could find about adding trusted applications etc and nothing worked even disabling firewall and Defense+. Uninstalling and reinstalling Comodo with just AV and Defense+ still wouldn’t work so I think the problem is with the Defense+ side. Only when I completely uninstalled Comodo would Jbuilder run again. I had previously been running JBuilder OK with ZoneAlarm which is now removed.

Other Java apps work OK, but JBuilder has its own Java 1.4 jdk

One sort of rather unsatisfactory work-around was to go into the jBuilder.config and set it to use a max heap of 350M rather than the 70% available memory which was the default. It would then run OK. Anything more than 350M would bring back the problem so I suspect some initial call to check on heap size is failing when Defense+ is installed.