Java Error on some sites

Windows XP, SP3, 32-bit
AMD Processor family.

Comodo Dragon Browser 23.4.0.0

After most-recent release of a stable update which I accepted as an update for installation and relaunch, certain sites are giving a Java error. The error states that Java is blocked, and you must update before it will execute. The alternate is to allow it to run one time as an exception.

I have the latest Java installed, version 7.10, build 1.7.0_10-b18

Following the prompt from CD, I clicked to download and install what it thinks is the latest version. When starting the offered Java installer it says that version is already installed. I proceeded with th einstall anyway. After restarting the system and restarting the browser the same problem persists on some sites.

Site to test this with is: myspeed.visualware.com and run the internet speed test which is in wide use by some.

You cal select your geographical location, but when attempting to run the actual test you get the Java error from CD.

There is no way for me to determine if this is a problem with the Visualware web site or not.

I can run the Java applet at this web site using IE8 (of all things), and the current version of FireFox without an issue.

Process of elimination suggests that something in how CD is recognizing Java is the issue.

Note that there are 2 other versions of Java installed that the Java installer has never removed, and those usually remain in effect for legacy needs. Might the presence of these older versions be causing the problem?

Hi and welcome sunclad,
I would be more inclined to think it is a browser setting, I would individually disable each of the three settings below found under Privacy in the Advanced settings and try again.

  • Do not allow websites to know where you came from (suppress HTTP Referrer header)
  • Enable malware domain filtering (Comodo Secure DNS)
  • Send a ‘Do Not Track’ request with your browsing traffic

If the above fails try disabling any 3rd party extensions.


I changed the settings as suggested and shut off extensions. The only extensions installed were those that came with the Comodo Browser.

I closed the browser and re-launched with no effect. Should I restart the system? Usually a re-launch of a browser after changing settings is sufficient.

Thanks for the response by the way. This not a critical item. Just an annoyance.

Addendum… Earlier versions of Comodo browser that I have had installed did not manifest this problem. I’ve been running CD for well over a year now. It’s a nice flavor.

Hi sunclad,
I am not sure what is happening, you could check to see if Java is active in Dragon and up to date in the following link.
TestJava

Other than that I hope the Devs take a look or hope others post some suggestions.
Thanks.

I tried the Java test site as linked and it gave the same error. It says that Java is out of date and is blocked. It offers to download the updated version (at Java) which I already have, or run one-time only with the available version.

As noted I have the latest Java installed and it works with the other browsers I have available, i.e. Firefox, Opera, etc.

Even after following CD’s offer to download and (re) install it has the same issue.

It would be interesting to know if others have the same manifestation at the test site. If not maybe I have an issue and need to do a fresh install.

Additional update…

As an experiment I checked my installation of Google Chrome and it has the same problem.

The suggestion is that there may be a problem with the underlying version of Chrome.

Both of these are installed and working on a 2nd hard drive and not the “C” drive by the way. I have never had an issue with this configuration.

Latest Java worked before updating CD to 24. Now it doesn’t.

Seems to be working here with 24.01 and Java 7/11. Did you give permission for the Java applet to run?

[attachment deleted by admin]

Update - 1/16/2013 at 12:07:34 PM Eastern USA Time

Further checks after the latest installation of Comodo Browser update offered this date. Version showing is 24.1.0.0.

I scrolled down through the plugins and found that it is not recognizing the latest version of Java at 7-11.

The message showing on the Comodo Browser plugins page is:


Java™ (2 files) - Version: 10.5.1.255 Download Critical Security Update
Next Generation Java Plug-in 10.5.1 for Mozilla browsers

When I was offered the download of the latest version of Java by Comodo Browser I got the 7-11 update. Of course it was already installed and the Java installer asked if I wanted to re-install it, which I did. However Comodo is still not recognizing 7.11

I checked to see which versions are installed and I have 1.6.0_22, 1.6.0_26 (legacy needs), and 1.7.0_11

So what next?

Note that I also have Google Chrome installed on the same hard drive. Do they share any files as a Chrome type browser?

I’m beginning to think I need to purge my system of Comodo Browser and start over. ??

…Sunclad,
from all of the research I have done, the rule for Java is to have ONLY the current version installed for vulnerability reasons - legacy has nothing to do with it - uninstall all old versions - especially within the last YEAR, Java has been plagued with security issues - the whole reason for Java updates is security, so the infections can’t get in - with an old version in there, you may already be infected - this, (old versions) probably doesn’t have anything to do /w/ the glitch, as I see others with the problem on here - but for your own good, get rid of all old ones - Java as well as Adobe, as well as Microsoft are in my opinion, sloppy /w/ updates & security, but, especially Oracle (Java owners) - I see lots of negative feedback about the secure state of a lot of their software - if you don’t need it UNINSTALL IT - here’s some reads…

…I uninstalled it completely in Aug 2012 so I will never see any problems about it, & have never been infected with a Java exploit since, & couldn’t be happier - THE POISON IS GONE…

Of course I did! Works fine on IE btw. Have the latest Java update as well. I have Windows 7.

Oh, and I have run numerous security scans…nothing wrong there.

Perhaps, if you could provide some specifics, we may find a solution. If you’re using Comodo DNS you might try disabling and then testing any ‘problem’ sites.

Update: 1/19/2013 at 12:50:12 PM Eastern USA Time

This plugin (quoted above) appears to be the problem (reported earlier).

When I disable it in the CD Plugins screen, the site I go to for speed testing says that Java is disabled and the site cannot run the test (line speed test).

When I re-enable it, the CD browser pops up that Java is out of date and you need to update. Of course I have long since updated to the latest version (1.7.0_11) which is running fine. The browser offers me to update Java (already done) or “Run this one time.”

My only option then is to click on “Run one time.”

So this needs to be referred by the development team to Java-Oracle.

Bug. - The plugin needs to be updated. Installer needs to remove the old plugin and replace it with a new one

DMK

Problem persists with 24.2 update.

1/31/2013

Latest Java update 7.13 (1.7.0_13 b-20) corrects this problem.

It includes an update to the Java plugin for Chrome. The revised plugin is tagged as follows:

Java™ (2 files) - Version: 10.13.2.20
Next Generation Java Plug-in 10.13.2 for Mozilla browsers