Java applet cannot be loaded in Firefox

Hi guys,

at first, I like the Comodo Firewall!!!

I have a problem using Comodo Firewall and SUN Java 6u2 in Firefox.

When loading a java applet, the console shows the following error: Resource temporarily unavailable: recv failed

I opened firefox in MSDEV in order to debug the result of the recv operation in Java_java_net_SocketInputStream_socketRead0. I found out that when this error is raised, the result of WSAGetLastError is 10035 (WSAEWouldBlock).

That’s curious since according to the specs, this error is only raised on non-blocking sockets, but looking thru the source code of the JVM, I am perfectly sure that the socket is in blocking state.

This also happens when Comodo Firewall is switched off. This error started to occur when I installed Comodo Firewall a couple of days ago.

So I’d like to know whether you Comodo guys tamper with the sockets so that a blocking socket could return WSAEWouldBlock.

I haven’t yet tried after uninstalling Comodo. Is there a possiblity to completly disable Comodo without deinstalling? (Can’t stop the Comodo Agent…)



Have you tried to disable cpf.exe from the traybar and then close cmdagent.exe afterwards?
Right click CPF traybar icon, choose ‘Exit’, then open up Task Manager and kill the process ‘cmdagent.exe’

About Java, I don’t know, never had any problems with Java and CPF.