iTunes and internet radio stations

Since I installed Comodo Personal Firewall I can’t iTunes radio stations to be displayed. When I select a radio category iTunes shows a message stating “Contacting tunning service… Refreshing Category List” and that all… after a long time it popups an error message saying that there was a problem connecting with the tunning service.

Here is what I tried so far:

a) Enable port 5353 for In/Out
b) Disable all trafic rules
c) Change firewall mode to “Allow all”
d) Setting “allow all activities for this application” in CPF app config.

Any ideas?

My configuration:
Windows XP SP2
AVG Free 7.5
784 MB RAM


Check CPFs log file to see what is being blocked. The log file is your feedback for things like this, it should indicate what rules you need to create/consider based on what is being blocking with the current rule set.

thank you for answer. I checked CPF log and cound’t find any entry related to iTunes. So I cleared all logs and tried again… no log entry was created.

Any ideas? Why blocking remains even after I change to “Allow all” mode? I have the same problem (blocking after setting Alllow all mode) with LimeWirte, KCeasy and eMule.

Victor Espina

Sorry, I should have spotted that (doesn’t work with CPF set to “Allow All”) before. It is very odd that eMule, KCeasy & Lime Write all fail with CPF set to “Allow All”. Do they work with CPF set to “Custom”?

Do you have any other security software installed?

No, they don’t work in custom mode… that’s the main reason I’ve trying all other options, including setting “allow all”.

I don’t have any other security software installed. Just AVG Antivirus. I do have a proxy software running in my PC to allow others PC in my home to share my Inet connection, but I’m connecting to Inet directly and not through this proxy.

The only way to get this programs to work is to set “Allow all” mode and then restart my windows… but if I change to “Custom” mode again, programs stops accessing internet.


The lack of CPF Log entries is very confusing & implies that something fundamentally is wrong. Does anything work at all with CPF set to “Custom”?

Have you set-up a Trusted Zone in CPF for your LAN? Also does the output of “IPCONFIG /ALL” look normal?

Everything else is working with CPF in Custom Mode:

FTP clients
MSN Messenger
AVG Personal Emailer
Downloads managers

And CPF itself is working as expected… everytime an application tries to access internet for the first time, CPF popups a dialog asking me to give or deny access to that apps.

Appearenly the problem its just with applications that make some particular connections, like P2P programs… and again, what really have me confused its the fact that setting Allow all mode doesn’t seems to be working…

Victor Espina

I used the same firewall software (Sygate Personal Firewall) for year without any problems… unfurtunatelly, this app was discontinued and I found out about CPF running a google search for “best free personal firewall”… I downloaded it, installed it and was very happy with it’s simple interface and esasy to use… but this kind of “rare” problemas have me very dissapointed…

I really hope to solve this problemas, because I think that CPF its a great app…

Victor Espina

I also used SPF Pro & dropped it for the same reason you did… anyway, I asked if you had set-up a Trusted Zone in CPF for your LAN… have you?

Also can you confirm that the last rule in the Network Monitor is a Block & Log (IP In/Out) Any - Any? (it would be useful if you could post a screen shot of your Network Monitor rules).

If this rule is absent, then that’s why you’re not getting anything in CPFs Log. In fact, it’s the only reason that I can think of that would stop you getting entries in the Log & that “Allow All” doesn’t seem to make any difference. Since, without that that final block rule CPF is, effectively, always set to “Allow All” (ie. all inbound connections are allowed).

I missed that question about Trusted zone… sorry for that. No, I haven’t set any trusted zone.

But I looked for that default bloking rule and it seems that I accidentally deleted it at some point. Do you know how to recreate it ?

Thanks a lot for your help so far.


The default blocking rule in network monitor looks like this.
Action : Block & Log
Protocol : IP
Direction : In/Out
Source IP : Any
Destination IP : Any
IP Details : Any

It will appear in bottom of the list when you click ok, so you can leave it there.
Now you should get some log entries.
If you are behind a router you should Define a trusted network.

If you want programs like P2P to work, you need to open port(s) for them in network monitor.
It should look something like this if your program uses the port 52222.
Action : Allow
Protocol : TCP or UDP
Direction : In
Source IP : Any
Destination IP : Any
Source Port : Any
Destination Port : A single port : 52222 (or a port range like 52222-52224)
Move the rule to the top of the list with the “Move up” button.
Just to be sure, restart CPF, and in some cases there has been an issue with CPF, so that you have to restart the computer.

Hope this helps. If not, post the log.

Well my friend, it seems that the most basic and usefull principle in computing has just proved itself again: It something should work and it doesn’t… restart and try again!

I created the blocking rule, restarted my PC and know iTunes radio tunning is working pretty fine. Limewire is working too, and KCeasy is now getting connected to Ares and OpenFT networks, but still can’t connect to FastTrack and Gnutella networks… but I’m sure that there is a solution for this in the forum.

Thanks a lot for your help and your time.

Victor Espina

If you check your log, when running those programs that still don’t work, and sees a lot of ICMP blocks, You can make a rule for that.
TRY a rule that allow ALL ICMP out.

Action : Allow (& Log)
Protocol : ICMP
Direction : Out
Source IP : Any (zone)
Destination IP : Any
ICMP Details : Any

If it works, you can fine tune it, using the log messages.
Don’t forget a reboot… :wink: ;D

Today I had a tele-meeting with my boss… I started my Skype… and guess what? CPF BLOCKED MY SKYPE!!! even after marking skype with the “Allow all activities” checkbox…

I had enough of this piece of ■■■■!

I just uninstall this #W%#% and reinstall my old, faithfull and WORKING Sygate Personal Firewall…

Thanks a lot for your help, specially kail and AOwl, but I need to work, not to be worried about problems caused by my firewall.


Victor Espina

Sorry to hear that you uninstall it.
I think that you could get it to work with a reinstall.
I use Skype, and I don’t have any problems at all. No “special” settings required.
If you change your mind, and do reinstall, be sure to follow these steps.
When you install, choose auto settings.
Then you should “scan for known applications”. (security tasks)
Restart the firewall.
If you are behind a router, remember that you “define a new trusted network”. (security tasks)
Restart the firewall.

Welcome back. (CLY)

Thanks for your tips AOwl, but I think I will stay with SPF until something really better comes out. As I said, I don’t have the time to “fight” with speciall settings for something that should work as transparently as SPF does.


Victor Espina

Maybe you can try the new version that comes out 16th Nov. :wink:
Language support and some other stuff… ;D