It looks like most people are having an update error

Yea I have the same update error as everybody else I did everything I could.
I did the following steps as well as change the bases.cav in safe mode

Please try a clean install. Start with exporting your configuration to a folder that is not part of the Comodo folder under Program Files. This way you can restore your configuration after the reinstall.

Uninstall CIS and reboot. Then run Comodo System Cleaner to get rid off registry keys.

Then delete the Comodo folders under Program Files,
Program Files\Common Files, %username%\appdata\local, %username%\appdata\roaming\ and %username%\appdata\local\virtual store .

To be even more thorough open Device Manager and set it to show hidden devices under menu option View.
Then see if there are Comodo driver(s) left in non Plug and Play drivers. If so select the driver → click right → uninstall and reboot.

Now you should be good to give the install a try.

It does not work…

Sorry, no problems for me at all.

Is this recent or a longer standing problem for you?

If it is recent then try again. It is working here (five hours later). May be the server had a problem.

I voted No.

Upates have always worked for me, so it’s not everybody.

It’s too many…(having problems) :frowning:

My update stops at 30%. This started a week ago.

Had the same problem on one of my other computers some months ago and could only solve it with a complete uninstall/reinstall.

If you have imported configuration file from the previous versions then Make sure the registry value of ‘Update path’ and ‘Update URL’ (at right pane) under
'HKEY_LOCAL_MACHINE\SYSTEM\Software\Comodo\Firewall Pro\Configurations\0\AV\Settings' is as follows

CIS 3.8:
Update path must have the value : av/updates38
Update URL must have :

Update path must have the value : av/beta39
Update URL must have :

Also, Verify this for
'HKEY_LOCAL_MACHINE\SYSTEM\Software\Comodo\Firewall Pro\Configurations[b]1[/b]\AV\Settings'
'HKEY_LOCAL_MACHINE\SYSTEM\Software\Comodo\Firewall Pro\Configurations[b]2[/b]\AV\Settings' and etc


All my registry information is exactly as stated above, but updates still doesn’t work.

What’s the ‘virus signature database’ version displaying under ‘About’ section of CIS?
What is your CIS version?


My product version is: 3.8.65951.477
Virus signature version is: 1107

Are you able to download the following via browser

If not, Problem is in connection to the server.


The .cav file downloads fine but I havn’t figured out how to install the file manually yet.

Try this workaround to try to get the update to work:

  1. Boot to safe mode
  2. Go to C:\Program Files\COMODO\COMODO Internet Security\scanners
  3. Delete or rename bases.cav
  4. Go to C:\Program Files\COMODO\COMODO Internet Security\repair
  5. Copy bases.cav from C:\Program Files\COMODO\COMODO Internet Security\repair to C:\Program Files\COMODO\COMODO Internet Security\scanners
  6. Reboot
  7. Open CIS and update virus defs

What is the virus signature version for CIS 3.9.73525.491?
Today, mine is 1116. It’s Ok?
where we can verify the daily signature of virus? What place in the forum?


Yes 1116 is newest db.

This link with additions is updated daily.


Thanks EricJH, your solution made CAV finally update to the latest virus signature database.
However, the cause to the problem is still unclear.

May be a corrupted download of one of the bases files.

db 1116

Thanks for the reply. So far all is Ok with CIS 3.9 Beta. :slight_smile:

lol sorry for the long time no post. I started testing the beta and it updated to the latest virus definitions. So far the beta is awesome :-TU :). So what EricJH did worked for 3.8?