issue with CFP3

I have discovered an issue with CFP3. I am posting it here only because CIS includes CFP, and the issue may also be true with the included CAV.
I log into my computer. Everything is running normal. I have several programs running 24/7 so I usually just lock the computer when I am away.
My girlfriend has a wireless laptop, but sometimes prefers to log into the net with this computer instead of her own (I am still logged in).
This is where the problem is.
She does whatever, then logs out. Later when I log back in (unlock my account), CFP is no longer running and must be restarted.
This means my computer has been unprotected for whatever period of time until I restart CFP.
Is there a setting on my end that needs to be changed, or is this something the developers never considered when coding this?
Will CIS have the same issue when it is released?
(inquiring minds want to know)

As to the suggestion of the icon being missing but the firewall still running, I could not recreate the problem myself.
I have seen this on three separate times. I will have to verify this when next it happens, and discover what else was run during her login to see if that had anything to do with the disappearance.
I did think it was game playing, but I ran 5 different games (including Crysis) on my Gamer account (created just to play games with large overhead like Crysis), logged off, and re-logged on my account (I’m still logged in the whole time on my account, all programs running that normally run). Everything where it should be.
I will have to get back to you on that one.

Hello John :slight_smile:

So do you get this problem when switching user accounts?
Just to check if CPF3 is still running… Press CTRL+ALT+DEL go to process, cmdagent.exe should be running.

I will check that next time it happens.
Thank you.

Your welcome. Also if you can reopen comodo when it happens check the logs and post any screen shots if something is being blocked.

Comodo → Firewall → Events
Comodo → Defense±> Events

Firewall events show nothing, Defense+ shows one item repeatedly: LWEMon.exe (my wireless Logitech game controller). It is a safe item. I am not sure why it is being displayed in Defense+ events window.
Nothing being blocked that I can see.

Well if it’s not being blocked then that’s ok :stuck_out_tongue:

When you encounter the problem again let me know what happens…

you can be sure.
Thanks again.

I know when I was using XP and had Fast User Switching enabled, if I switched from one account to another (both accounts logged in) I had the same issue with the old Sygate firewall. It would be active (and send alerts, so I know it was active) but would no longer show up in the taskbar until I rebooted. Logging one user out before logging in a different user prevented this from happening. I have long since disabled Fast User Switching so I can’t verify if this is the same thing that is happening for you with Comodo, but it sure sounds like it.

Yeah I suspect it is when he is doing user switching, there has been cases of this with other users with comodo switching accounts

If I remember correctly, the Sygate helpfile actually stated that this was a known issue

Is the entry for LWEMon.exe (access memory)

“Is the entry for LWEMon.exe (access memory)

yes it is.

I presume it is CPF3 that it is trying to access if you want to add it as you have marked it safe go to Defence+/Advanced/Computer Security Policy posted screenshot for rest after adding click apply to all screens that are open.

[attachment deleted by admin]

Done. Will see if that corrects the problem. Thanks.

That hasn’t resolved the logging issue yet.
I have marked it safe, trusted application, software vendor is trusted (and signed).
It is still logging (this one event) as shown in the attached image.
What am I not setting correctly?

[attachment deleted by admin]

Hey, It’s because that isn’t the problem. That’s just showing you what has accessed the memory in ‘last week’

Those logs are for the past few minutes only (I have repeatedly cleared the log entries).
If I am barking up the wrong tree, then which tree should I be barking at?

Well, Isn’t your problem that you logg in after being away from the computer for a while, girlfriend loggs in\out of your comp… When you come back to your account cpf isn’t logged in?

I see you have CIS it should not make any difference this always worked in CPF3.
P.S. Could you please checked to make sure the entry is still there.

With respect to this issue, when this happens again I will verify what is or is not running by looking at running processes. (Girlfriend usually logs this computer when I am at work, not when I am home).
And yes, the scenario is that I am still logged into the computer, but CFP (might) not.