Issue when updating my NVDIA GeForce GT 520


I AM on Windows 10, 64 bit - Comodo Internet Security

  • Viruscope - Active
  • AutoSandox - Active
  • HIPS - Secure
  • Firewall - Secure
  • Antivirus - Complete

When a new video driver is released from the NVDIA software IF i start the update without disable completely all services of Comodo by change the status of the PC from Secure to Risk the updates fail

So can this issue be resolved from Comodo? Is not very nice to have to be forced to turn off all Comodo protections Service for install the graphic update.

I guess the automatic sandbox is kicking in. Can you check the Defense + Logs and post a screenshot of them? Can you confirm the drivers are digitally signed and that the signature is on the Trusted Vendors List?

Since you are posting in the AV help board. Can you also check the AV logs to see if the AV is interfering?

Hi Eric, can be the HIPS who I have active on Secure mode… maybe Comodo should have an exception for NVDIA file check for Signed NVDIA and allow it.
Actually the log is empty because i had some issue on reinstalling Comodo.

Maybe I need to test next time a NVDIA update is released but as you can understand is my work PC i can’t do test here… if the setup of NVDIA fail i have issue on all desktop with all icon… i can’t do test here on this PC.

I will see what i can do. Thanks.

I have seen it happen when installing that the installer unpacks a temp file with random name which is not recognised. Even though I tell that rundll32.exe (which unpacks the temp file) gets the Installer/Updater policy the automatic sandbox takes precedence and the installer gets run sandboxed. Since the temp file has a random name the same thing will happen when I start the installer again. In that case I temporarily disable the autosandbox… :-\

Also if all services of comodo are disable NVDIA did not install. I need to presso on comodo and exit completly for comodo for see success install of NVDIA.
This issue is something COMODO have to work on…

The issue is not only with GeFORCE but also if you try to update the video driver from Device Manager (3 Ways to Update Your Video Card Drivers on Windows 7 - wikiHow)

I just installed CAV so I haven’t tried this but according to Chiron’s guide, if you run CAV/CIS in game mode - it basically puts it in ‘Training Mode’ which will “create automatic allow rules for all running applications.”
Obviously this should be switched off as soon as the driver is installed.

Also, where do you find your GForce driver?
If you haven’t already done so, I would suggest installing the “GForce Experience” program.
It not only tweaks your game settings automatically, but it checks for new drivers and installs them. I love this program.

GForce Experience downloaded from the NVDIA website, also this official program not run well with Comodo active, the program look for the correct driver and when the driver is installed tha installation fail. I need deactivate all Comodo service and exit completely from Comodo than restart install and it’s done with success.

You don’t need to deactivate the services. Simply exit from CIS (right click the CIS icon in the tray) and the Nvidia drivers will install without error.

It’s not beautiful to say. Maybe Comodo should work for not make user with issue, I AM not the only one see an error when update Screen driver and is not easy to understand is comodo who make issue. Thanks.
Love Comodo :slight_smile:

IT Works! Only exit from Comodo and NVDIA driver installed successfully! This should be fixed. :smiley:
Thank you John

Why that happens?

This issue still be present.
Seems not solved from Comodo. Every time there are NVIDIA update the install fail if I don’t press exit on Comodo.
Now I will infor also NVIDIA about this issue with Comodo.

I think I will open a ticket now for this issue.

It appears to be a Windows 10 problem which was fixed in December, if you receiving the quick updates.

Nothing to do with CIS.

Will post link later when I find the topic.


It appears to be a Windows 10 problem which was fixed in December, if you receiving the quick updates.

Nothing to do with CIS.

Will post link later when I find the topic.


Hi Dennis,
seems to be a Windows 10 problem?

I press exit on Comodo Internet Security and lunch NVIDIA update and all goes OK and if I try to update with Comodo active the updates fail and you say is a Windows 10 issue?

I don’t believe.

Link plus quote post below.

It is beyond me to understand, why only exit the gui should do anything, as this does nothing to CIS actually functions :o

The wonders of Microsoft and Windows 10 never fail to amaze me :slight_smile:

Believe it or not I am afraid it is true.


I continue to think is a Comodo issue. My Windows 10 is updated.
When you close the antivirus and issue is resolved is an issue of the antivirus, not to Windows 10.

If was is issue with Windows 10 than the issue persist also without Comodo.

Feel free to think what you like :slight_smile:

The only thing I can point out is that exit/closing the gui/icon does nothing to CIS, apart from losing the ability to show alerts.

Thank you


BUT this resolve the issue. Very strange! :smiley: Because I have tested! :stuck_out_tongue: Thank you anyway. IF you Exit from Comodo works, if not updates fail.

Like I said before, Microsoft and Windows 10 never cease to amaze me the question is what is next.

Things disappearing from your computer without your knowledge, because it has been decided you do not need them :wink: