is windows firewall running???? [RESOLVED]

Hello everyone–I have comodo firewall latest 2.-- running. I also see this in the services that are running. I have the windows firewall turned off in control panel /windows firewall=off

Is this the regular firewall or a network firewall that should not be running.

I do not want to disable something that needs to be running–I did google it but did not dsee anything with the “-k” before the netsvcs

Windows Firewall/Internet Connection Sharing (ICS) [started/running–comodo pf also running]

Provides network address translation, addressing, name resolution and/or intrusion prevention services for a home or small office network.

C:\WINDOWS\System32\svchost.exe -k netsvcs.

I am having some problems with comodopf-- like opening a link from an email in the default browser where the browser has to be opened. I have set the default browser to allow everything and not check parent and it still happens (:AGY) It does not happen with windows firewall…

also the little/not so little pop up alert/window that pops up and asks me to allow or deny something to happen stays open for like 2 minutes [and it is always in the way] if I say yes and remember this action/ make a rule. I usually just click allow [and not to remeber this action] and it goes away.

any ideas are appreciated


If you click Windows Control Panel → Security Center, and check the Firewall setting, you’ll see what Windows is running as a firewall. Windows will recognize CFP 2.4 as a firewall product, and will report that if CFP is running. The Windows svchost.exe runs a very great many things, not all of which are enabled at any given time, so while the capability is present, it isn’t necessarily being used.

If you click Windows Start → Run, and enter “services.msc”, you’ll get a list of the background processes that are running on your machine. The CFP firewall itself will be listed as “Comodo Application Agent”. If it’s state is “started”, then CFP is running. The “Windows Firewall” service may also be running, but isn’t functioning as a firewall. At least, it isn’t on the machine that I’m using right now.

That CFP is giving you an alert about an outbound connection, is what CFP is designed to do. If you “allow & remember”, then you should only get the one alert. If you want to decrease the time from 2 minutes to some smaller value, open CFP and click Security → Advanced, Miscellaneous → Configure, and toward the bottom of the window, change the limit from 120 seconds to something you’re comfortable with, like maybe 30 seconds.

To know whether the Windows firewall in particular is activated (it can be disabled while its service is running), right-click on the icon that represents your connection in the notification tray of your taskbar. It’s like two small computers --you may have two of them and they can be crossed out in red, don’t worry. So right-click on this icon and select “change Windows firewall settings” or something like that. There you can see its state and also change it if you’re admin.

Thanks guys–I actually have dispay alerts unchecked??but still get them…The problem with the popup window is when I click remember this action and the click allow --the window stays open- it seems forever.Is there an adjustment for that. I don’t see one.

Why can it be made to disappear right after I make the decision for cpf to remember the action and allow or deny—let it do whatever it does without the pop up window getting in the way…

I will look in to the other windows firewall thing. I don’t think it is running,but there is something called

windows Firewall/internet connection sharing [ics]
started [automatic]and running now with cpf

all i=of the svchose.exe things running in the process are like 340k. one is using 7,340K its id is 1512

seems like a lot—2/3 of cpf ==11,400k.

Thanks for getting back…

That’s the service, but even if this is running the Windows firewall may be disabled, you must look in the notification tray.

I don’t quite understand your problem with CFP, you say that you click allow and remember and the popups persist? You’ll have to tell us what the popups say and what are you doing at the moment or some additional information.

all i=of the svchose.exe things running in the process are like 340k. one is using 7,340K its id is 1512

How are you getting these numbers? From the Windows Task Manager? These are an order of magnitude different from what is running on my machine. svchost.exe is like 4000k here in memory usage, and around 3000k in virtual memory size, as reported by Task Manager.

The CFP alerts should disappear as soon as you click allow or deny. Are you getting any kind of keyboard lag when you type?

Man I just wrote a long reply and tried to upload the wrong type image and lost it all—I hate when that happens

basically the popup disappears as soon as I click it unless I check remember this action–also if I click to show the libraries they hang around forever too.

I have cpf set to not show any alerts anyway. I should not be getting any right?

no keyboard lag ever

p4 2.26 ghz— winxp home— kaspersy av should have been updated to 7.0 [getting rid of kaspersky in a few days when updates stop]

[attachment deleted by admin]

:frowning: Sorry to hear that. You can backup to the clipboard (Ctrl+A, Ctrl+C) as you type, that’s what I do with long posts.

I don’t know for sure how CFP behaves with alerts disabled. Does it block anything not allowed without asking? If that’s the case that sure is safe and if it works for you because you’ve got all the rules you need, go ahead, but it sounds strange. :stuck_out_tongue:

Since you mention libraries, I think your problem may be chiefly the component monitor. You could try turning it to learning mode and trying again. Enable it back only once it’s learnt enough. Anyway I think that the component monitor is exceedingly noisy and any additional protection it grants is no big deal. You could disable it completely if it doesn’t behave even after having been set to learning mode for a time.

Thanks for the input. I may try setting it to learning mode again. i gotta fix it. I know that much.
Maybe I will reinstall [even if I don’t have to] for v3 and see what happens.

Thanks again…

Also, be aware that there are some issues about compatibility between Kaspersky and Comodo Firewall v2. I don’t know if it’s a particular Kaspersky version or not. Just that there are confirmed reports that some things just don’t work right with both products installed.

I am going with avira antivirus or the suite minus the firewall in a few days…I think it might be that especially since i have the 6.0—version. I should have updated, but I am too lazy :-[

I will post back next week when I switch…


Kaspersky was the problem. alerts now go away in about 5 seconds :BNC

New problem though—comodo fails to initialize with avira installed–I have to exit it and reatart it. It says it is initializing but never actually does although if I open it up it says exellent protection…New thread I guess (:NRD)

Good to hear that this problem was resolved, but a new one showed up. From your other topic, it looks like that was resolved also.

I’ll mark this topic as closed/resolved, and lock it for future reference. If you need it reopened, you can PM any of the moderators to unlock it.