Is there a manual and what's this installation error message?

Is there a manual for Memory Guardian? (Alternatively, I’d be grateful for an explaination of the function of the Add Application and Remove Application buttons. Am I supposed to add the applications I wish to be monitored?)

By the way, I did get an error message during the installation but it went on to apparently install satisfactorily with the icon in the systems tray.



I don’t think beta products (esp. something new like CMG) usually have manuals constructed yet. Once it becomes final I’m sure there will be one.

No, that is more for an “Exclusion” type of function. By Adding a program, you can specify custom features for it. You can only Remove applications that you have Added for custom settings.

By default, everything on the system is protected.

Hope that helps,


BTW, I’d be concerned about an error message during install. Do you remember (or write down) what it was?

I updated the thread title so that we can double-topic it.

Even it was a Windows error you can view it in the Event Viewer: Start > Run > type eventvwr > Look under both Application and System

We’re gonna to make the same look’n’feel for CMG as CFP 've got. So the GUI will be more user-friendly, and ofcourse it will include the documentation.

Many thanks for the clarification. The error message during installation was “Cannot Start Service” with “Code: 127”. Nevertheless, despite this message, Memory Guardian starts without any further error messages during boot-up/logon.

Thanks again.



What Operating System do you have?

Reason I ask, someone just posted the same error message here…;msg87341#msg87341



I’m also (like the other fellow) on Windows 2000 (SP4) (fully updated, of course) - sorry, I should have mentioned that. Furthermore, I’ve just checked in Services - something I should have done rather than assume all was well from the Systems Tray icon - and, whilst the “Comodo Memory Guardian Injector 32 bit” is listed in Services and set to Automatic, it is NOT running and when I tried to manually start it (as an Administrator) I got the following error message:

“Could not start the Comodo Memory Guardian Injector 32bit service on local computer. The service did not return an error. This could be and internal Windows errror or and internal service error.”

Thinking this might be due to my having non-essential services turned off, I looked on the Dependencies tab and found that CMG apparently doesn’t depend on other services.

Is there any further checks you want me to do e.g. repeating this info to the other forum thread you quoted? By the way, having got complacent over the years, I installed CMG in Normal Mode (i.e. not Safe Mode) and I didn’t bother to switch off anti-virus, BOClean, Comodo firewall etc…

You might try uninstall CMG in SafeMode, clean the registry of any leftover entries (specific and general), and then reinstall in SafeMode to avoid/rule out any conflicts.

It may simply be related to the OS, but we can hope…


I think windows2k (not 2k3) 've got too differencr architecture to run CMG. Win2k support will be added probably in the future.

//  The specified procedure could not be found.
#define ERROR_PROC_NOT_FOUND             127L

Followed your suggestion but the problem remains. I noticed during the installation or at some stage that this beta is for 2003/XP; so it’s not unreasonable that there’s a snag on 2k.

Many thanks for your kind help.


No problem; based on Tyler Durden’s post (right above yours), they have isolated an issue with W2K.

Note: Tyler is “the man” for CMG development.


I’m not the God, I’m a god (C) (:AGL)

Whew! I’m gonna step back, lest the lightning should 'sploit you… ;D