Is my Firewall Working???

Recent new user to Comodo Firewall. I am on XP SP3 with Verizon FiOS and my PC is connected 24/7 to the network. If I look at the Comodo summary under Network Defense My blocked intrusions is always 0. If I look at the Firewall Alert Log it never has any entries. For some reason I do not see any attempts and associated actions. I am using the product as is “out of the box” and have not applied any customized options. Everything is set to the defaults. Is there any way to test the firewall and/or do I need to make changes to some of the settings? Any help will be appreciated.

well, you can try this shield up test for stealth test:

and here’s for testing your outbound protection:


anyway, if you’re not using any torrent/p2p application,you may use stealth port wizard (at least this can give you those intrusion logs you want ;D )

go to CIS/firewall/common tasks/stealth port wizard
and choose block all incoming connections… , that should affect your firewall’s global rules

you’re fully protected with default setting though :stuck_out_tongue:

Thank you very much for the response. I ran the first link and the only thing that failed was I was responding to ping requests. Is this a possible requirement for my ISP? If not what do I need to do to stop this? Everything else showed up as being stealth mode. I did not use the stealth port wizard, should I? As long as I feel assured that I am being protected I don’t really need a log.

I read the second link but was not sure how you actually run the leak test. Can you point me to how to run the leak test?

Thanks again for your help.

You should check out the Guides by Kyle and John Buchanen in the CIS menu. There are some excellent set up tutorials provided there.

I went through the tutorials and changed how I had Comodo set up according to the instructions. However whenever I try the ShieldsUp test I still get a failure as my PC is responding to an ICMP Echo Request. I have added 2 Global rules blocking ICMP In for Echo Request and ICMP Out for Echo Reply but the test is still showing a failure for ping requests. What may I be missing?

Added: I did a ipconfig on my PC to see what my IP address is and it is a 192.x.x.x address yet ShieldsUp is reporting my IP address as 96.x.x.x which is owned by my ISP. So does this mean that my ISP is replying to the ping request and also the other tests of ShieldsUp rather than my PC?

The problem with the shields up test is that if you are behind a router, the test is actually testing the router, not your software firewall.

I wouldn’t be concerned about your router returning pings.