Is it installed?

I ran something in the sandbox and it installed. I reset sandbox.It is still in C\programs\etc but is not in programs and features. so is it installed? IOr is there a sandboxed C\programs\etc?

I think the sandbox puts things in " (Drive letter)\VTRoot\HarddiskVolume(Drive number)\ " it’s a hidden holder, so it looks like it’s installed.

Are you sure you didn’t miss click and as run admin while right clicking the executable to sandbox it?

No i ran in comodo sandbox. There are some folders but no exe. Hold on having trouble withthis post. Edit:- I thought I had a screenshot of the folder but cannot find

Here is a screenshot of the folders

[attachment deleted by admin]

Did you ran as partially limited?

If ran as “partially limited” it’s allowed to access non-protected folders/files from: Configure Sandbox, Sandbox Computer Security, Kiosk Software | Internet Security v6.3

I ran in comodo sandbox from the context menu. Now i right click tray auto sandbox set to untrusted. So that means i ran as untrusted?

Hi david banner,
Please note ‘Auto-Sandbox’ settings do not affect manual sandboxing.
Manual sandboxing (Including right click context menu) should run as fully virtualized regardless of the ‘Auto-Sandbox’ settings, unless it is added to the Sandbox list (See link below).
Configure the Sandbox

If the mentioned program is not on the sandbox list and the program is run from the right click ‘Run in Comodo Sandbox’, then this program should be running fully virtualized.
If the program is still dropping files on the real system after the above requirements are met, I would then regard this as a bug.
Bug Reports - CIS
Required Format For Reporting Bugs

Kind regards.
Edit: Corrected typo.

Thanks. Isn’t the screenshot the real system C:\Pogram files etc? Can you confirm the path to fully virtualised program?

It appears to be on the real system.

Virtualised path = C:\VTRoot\HarddiskVolumex\etc\etc, unless viewed within a virtualized environment.

OK but no exe. What i was actually doing was trying to run the file inside the sandbox prior to installation, to see if there were pre ticked toolbars etc.Should it not hav installed to the sandbox as a right click run in sandbox? Or is that for installed programs?

As far as I know it should have entirely installed in the sandbox only.
If the files/folders are viewed within a virtual environment, the files/folders will appear to be in the real system location.
Exit the sandbox entirely the view the files/folders on the real system.

OK i installed Speccy by ‘Run in Comodo Sandbox’ from the context menu. It is in C:\VTRoot\HarddiskVolume2\Program Files\Speccy. If updates to it were downoaded they would go to the C:\VTRoot?

Hi david banner,
To update Speccy, the new installer needs to be downloaded and run.
If you ‘check for updates’ while using (Within) a sandboxed version of Speccy, this will open your default browser in a virtual/sandboxed environment.
If you download the installer from the sandboxed browser, the new Speccy installer will only be available in a sandboxed environment.
Running the installer (Sandboxed in this case) will update the sandboxed version of Speccy and should not effect the real system.

If you were to download the new installer non virtualised and didn’t select ‘Run in Comodo Sandbox’ then it will install the new version on the real system, unless you run the installer within Virtual Desktop in which case the entire system is running virtualised.
Starting the Virtual Desktop-Comodo Help

I hope that makes sense and helps.

Configure Sandbox, Sandbox Computer Security, Kiosk Software | Internet Security v6.3 I do not see fully virtualised on the list of options

If you do not set a restriction level, CIS will automatically apply a level of 'Fully Virtualized'.

@captainsticks. Thanks I found that in the meantime

Yes it makes sense, very helpful. Thanks
The problem program is now in the sandbox fully virtualised. But when it takes snapshots it is set to output them to a path on the real system. Maybe it will not be allowed to. I tried to create a new output folder in the sandbox but it said folder did not exist even though it did

Hi david banner,
Saved snapshots from within a sandboxed Speccy will not be saved to the real system.
It will appear to be saving to a real system folder, but the file will not be available in a non virtual environment.
An image of the folder is saved in the VTRoot folder.

Thanks captainsticks

You are welcome,
One thing I have noticed, is that Speccy doesn’t function correctly while sandboxed.
It shows the following message for most system components.
‘The specified service does not exist as an installed service’.

Only using speccy toexperiment as know it is safe