Is Comodo Firewall Pro messing up WINSOCK?

Slowly today after uninstalling Comodo 2.3 and installing 2.4 everything associated with the internet and email got messed up.

  1. It started with my outgoing mail server, couldn’t send but could receive mail
  2. Then Certain websites wouldn’t pull up
  3. Then I couldn’t send or receive email
  4. Finally I lost all internet connectivity

I ran a Winsock repair program and seem to have functionality now.

Is this a known bug?

Ruinning Windows XP SP2. IE 7. Outlook Express as my mail client

The answer is yes, it does replace some Winsock settings in order to control traffic. If you look in your CPF install folder you’ll actually see a backup .reg file of your original settings.

The uninstall should have restored these (your original values), but the reinstall should have replaced them again.

Sounds like you had a an install/reinstall issue. Do you have any other security software that would have been protecting your registry while the comodo was uninstalling/reinstalling and needing to update your registry?

I’m concerned that if you have “replaced” your winsock post Comodo install, that you might have lost some important cpf function. I’m feeling that you should uninstall CPF once more and retest quickly that your winsock is still intact at its defaults… if not then “fix” these settings before reinstalling CPF.

Thank you. I will uninstall and reinstall this weekend and get back to you.

After install on two PC’s and loss of internet connection, I discovered that on both computers, the TCP/IP filtering was changed. The “activate TCP/IP filtering” was changed from checked to unchecked and the “allow all” was changed to “allow only”.

Solo if you reinstall and don’t have a connection, go in to properties of TCP/IP and check all settings.
It would be interesting to know if you got the same problem.

Where would I find this info that is either checked or unchecked?

I run Windows XP Sp2.

Go to your network connections (control panel). Right click your connection and click on properties. Click on internet protocol (TCP/IP) and click on the properties button below. On the first tab click on the advanced button. On the last tab click on TCP/IP filtering and click on properties.Check that activate TCP/IP filtering is checked and the others should be on allow all.

Comodo Firewall does not change any wisock settings. Those components are called Winsock LSP(Layered Socket Provider) interface DLLs. CFP does not have such a component. It uses its own kernel mode components.

So your problem should be somethihg else.