Is Comodo blocking active scripts/Java?

I am plagued by a popup when I click on all sorts of web pages, on the lines of:
“A runtime error has occurred. Do you wish to debug?
Line: 603 Error: object expected.”

Here is the latest page that gave me this popup (in case you want to check its scripts…) :

I have been working through the Microsoft knowledgebase suggestions on this (Script errors in Internet Explorer - Browsers | Microsoft Learn) and about the only point left to check is “firewalls can be configured to block Active scripting, ActiveX controls, or Java programs”.

  • How can I tell if I have that setting activated or not?

Note: They also suggest to check if “the scripting engine on your computer is corrupted or outdated.”

  • How would I know and how would i get an update? ??? (What is my scripting engine likely to be?)

Firewall: Comodo Firewall Pro
Antivirus: Avast! 4.8 Home (NOTE: I don’t know how to find the relevant Avast! settings either…)
Browser: IE 7
Anti-spyware: SpywareBlaster

Hey, guess what? The “Runtime error - debug?” problem disappeared after a tip-off to install & run SpyBot. (Looks like SpywareBlaster 4.1 failed me there.)

  • So Comodo Firewall Pro is innocent :slight_smile:

Before that I did some more homework and found Windows Script 5.7 but when I started to install it, it detected that my Windows XP Pro SP3 already includes that. So it looks like my scripting engine wasn’t corrupt either.

My Google search on the “Runtime error - do you wish to debug?” problem showed a consistent belief out there that this is the way to fix it: IE > Tools > Advanced > Disable script debugging.

For anyone who arrived at this post because they are getting that popup all the time regardless of that setting in IE, my recommendation is: Try SpyBot first.

Sorry, that should read.
IE > Tools > Internet Options > Advanced > Disable script debugging

  • Not that it matters, as that solution doesn’t work ;D

Please disable the logging of Javascript errors. Not many sites write impeccable Javascript and end users don`t need that information.

EricJH -
Where do I find that setting?