Is a windows ICS network working for anyone using CPF3?

Like quite a few others with previously working ICS network, I too upgraded to CPF3, and found the host computer on the network firewalling out the client computer on the network.

I have received quite compassionate extra mile support, have tried to follow the advice to the letter, but I still have the same results. CPF3 firewalls out the client computer on the network. If I set CPF3 to disable on the host computer, the client computer gets correct internet access. And at least for me, CPF3 works flawless on both the host and client computer otherwise. But CPF3 refuses to work together in a co-operating ICS network. And judging by other posters who followed the same advice I did, it does not work for them either. And now I am advised to wait a few days until a fix is developed.

But now its time for me to ask a question.

  1. Did anyone have the pleasant experience of having CPF3 configure a properly working ICS network? Or to put it another way, if it works for some and not for others, is it due to something some people did wrong in the install, or is the different result due to some some common factor in their computer configuration? An example of such differences could be due to a given video card or some given program on their computer that just throws the networking aspects of CPF3 for a total loop.—or something similar but related in the way of a common factor.

But if that above possible working hypothesis is going to be explored, it would help to first know if anyone got an ICS network working right with CPF3?

So in the way of a poll, please report results.

Sorry, but I have a wireless router for sharing the connection. If you are interested there is a discussion on:

I got it working with xp ics and CPF3, here’s what I did…I first disable the the Defense+, then I disabled the firewall to let and Ics session set up from host pc. then I re enabled the firewall in training mode, then I went into the firewall logs and found the ip address of the ics pc. I then created a custom global policy ( advanced >predefined policy) to allow all outbound TCP or UDP from that ip address (the ics client) to any address on any source port and any destination port. This doesnt give the client the full protection of Comodo, but it allows the client to connect. I was then able to raise the firewall to train with safe mode level and still allow the client to connect. I really had to play around with it to create a policy that wasnt linked to an application, and then THIS IS VERY IMPORTANT- I HAD TO MOVE UP THE POLICY SO THAT IT WAS THE SECOND HIGHEST IN THE LIST OF POLICIES, (ABOVE THE BLOCK EVERYTHING ELSE).

Two details - first, I assume you know about the Firewall>Advanced>Firewall Behavior Settings>Alert Settings tab (Check the “This computer is an Internet connection gateway…” box). This is necessary on the computer hosting the connection.

Second, the policy described by monkeywrenchit is fine - the firewall on the guest computer will protect it and there is no opening into the host computer using that configuration.

The question is where that fossil of a thread got unburied. The point is that ICS COULD NOT work with the the original versions of comodo So at the time, it was important to establish the fact of could it work or could it not. Why waste time trying the impossible?

And the ICS problem was fixed only after the release of comodo versions And the extra steps needed to get ICS working with those later versions have long ago been posted.

But I suppose the revisit to the issue can’t hurt. But its now doable when it was not before.

as a newbie I brought it up because even with the I am still having difficulties with ICS even though I have the advances setting (this is an ics server ) check box enabled because my pc is an ICS server using a USB sprint EVDO modem. When I did an IP config release/renew on the client I lost ICS functionality and then even after editing the ICS firewall policy to contain the correct ip address of the client, it still wouldn’t work. I have it disabled at this point and am trusting the flimsy xp firewall because that is my only option. Perhaps I should have started a new thread.

To Monkeywrechit,

While I Can get some vague ideas of how you set ICS up the first time, its hard to see exactly how step by step you did it. But bottom line, you later reset the ip address of the client computer and now can’t get ICS working again.

But if win xp is the OS for both the host and client computers, other than the assumed wireless modem,
your set up is similar to mine. And I got my set up working using network zones and it sure seems like you used some totally different method.

I am sure willing to help you as are other people, but it would help to have more step by step detail.

Especially on the host computer, we would need what rules are set for firewall–my network zones and also the name of that zone. Then do the same for the client computer. It would help to get the ip addresses of both the host and client computer. ( you can get that by going windows start–select run–type cmd and then enter in the dialog box—and then type ipconfig /all ) (you can also take the time to set a static client address so a release renew won’t change things with microsoft knowledgebase article KB 309642) But I am assuming you have a host ip address of
and a client address of 192.168.0.x where x is some number between 2 and 254.

But at this point lets give it rest, get the info from you, and then go from there.