IPSec Services??? Speed & Duplex - LAN Card??

IPSec Services: IPSec Services failed to get the complete list of network interfaces on the machine. This can be a potential security hazard to the machine since some of the network interfaces may not get the protection as desired by the applied IPSec filters. Please run IPSec monitor snap-in to further diagnose the problem.

EventsViewer - Security - FailureAudit - IPSec Services - Whats this error?? How can I solve this??

What is Speed & Duplex?? The reason I am asking this coz 4 years back my service provider said that my LAN Card is damaged thats why I am not able to connect to the net. I showed the Laptop to 2 Technicians & they confirmed it. They gave me an alternative to use External LAN Card. Since then I was using External LAN Card. Yesterday I just thought to try to connect to the internet through the damaged inbuilt LAN Card & I wasn’t able to connect to the net. I compared all the settings of inbuilt & external LAN Card. I found that all the settings were same except speed & duplex. In external LAN card, speed & duplex was set to 10 base T Duplex & in inbuilt it was set to 10MB Half. So I tried with 10 MB Full but then too I wasn’t able to connect to the net. So I uninstalled the inbuilt LAN card & Windows installed it automatically. I found out that the default settings for speed & duplex was auto, so I tried with the auto setting & I was able to connect to the net. The net & LAN card both are working fine with no probs at all. My net connection is local cable connection 4mbps.

Now I am thinking, is this a miracle that after 4 years the damaged LAN card started to work?? or speed & duplex is an important factor related to net & the default setting i.e auto played the important part?? Is speed & duplex setting that important for internet??

WIN XP SP3 fully updated


Anyone here plzz…


The IPSec error is quite often caused when either adding or removing plug and play network adapter cards, which I imagine is why you’re seeing this now. If you don’t have a need for IPSec (only needed in an Active Directory Domain or for security when using a VPN), you can disable the service.

Open the start menu - Run services.msc and disable/Stop the IPSec Policy agent

Network Adapter Cards are notoriously difficult to troubleshoot and because of the relatively inexpensive cost, are simply replaced. The fact that your old card appears to be working again, may simply mean there was no real problem to begin with.

The terms Speed and Duplex refer to the rate and direction at which data flows through the cable, for example, 10Mbps simply means 10 Megabits per second. 100Mbps = 100 Megabits per second and so on. Duplex is how the data flows. Half duplex means the data flows in both directions but in only one direction at a time. With Full duplex, data flows in both directions at the same time.

If you know what your network speed and duplex requirements are, you can set these manually, otherwise leave it as Auto-configured.

Thanxx replying.

The IPSEC error is there only when I connect to the net. I connect to the net through my ISP’s Dialer & have to enter ID & Password.

I have a 4mbps connection & its working fine with no probs at all with the speed or anything. But my Local Area Connection - Properties - Status - is blank i.e status shows no info. Attached is the screenshot. Details too shows nothing.


[attachment deleted by admin]

You don’t mention which event ID is associated with this error and there are several, I’m guessing it’s ID 615? As I said previously, the most likely cause of this is associated with your network adapters, more than likely IPSecPol is seeing your old adapter as a phantom device, which it cannot enumerate correctly and thus produces the error.

You could try looking at the problem with the IP Security Monitor snap-in:

  1. Click Start, click Run, type MMC, and then click OK.
  2. Click File, click Add/Remove Snap-in, and then click Add.
  3. Click IP Security Monitor, and then click Add.
  4. Click Close, and then click OK.

But I seriously doubt it will tell you anything of use.

I’d also check to see what ‘hidden devices’ Device manager knows about. You can do a search on how to do this for your version of Windows.

As I said, if you’re not using IPSec, disable the service.

How can I check for the old network adapters which ipsec is seeing as a phantom device??


The search-bar at the top of your browser is your friend :stuck_out_tongue:

Device Manager does not display devices that are not connected to …

Device Manager : Hidden Devices

Hi Naren,

Where do you connect this cable to, what device is that?
It is likely that you have a 10Mbps connection to that device and that this device has a (limited) link to the ISP. On a LAN/Cable network most of the times the speed is shaped or policed which means that you drive with the brake on it 10Mbps link - Max 4Mbps speed.

If it’s bridged it could be that there are no IP’s on the adapter.

What type of dial-up connection is used? L2TP, PPP etc?

Hi Ronny,
I have a 4mbps broadband connection. The internet wire from the terrace of my building enters through the window of my room & is directly attached to the laptop. I dont know much about these things. I think its a PPP connection. The LAN cards TCP/IP properties shows obtain IP & DNS address automatically. I connect to the net through service providers dialer. The dialer is created by typing pppoecfg in the Start - Run. A pppoe services configuration window opens & a tab named query services is clicked which shows the name of the service provider & I have to select it & click on create dial-up connection & a dialer is created. With ID & Password I connect to the net through the dialer. If I check ipconfig /all there is info only about ppp adapter connection to the service provider like description - wan ppp/slip interface, dhcp enabled - no, etc. No info about the LAN card. Double click on LAN card then click on support & details shows no info. Double clicking on dialer then details shows device name - pppoewinmini port, device type - isdn, server type - ppp, transports - tcp/ip, authentication - md5 chap, compression - none, ppp multilinking framing - off, server & client ip address. Hope these infos helps.


Your connection type is pppoe, which uses the ppp mini port adapter, not the LAN adapter. Hhence little or no information on the LAN adapter, unless you’ve configured a LAN connection. If anything, by default,it might offer an IP address starting with 169…

Did you look in device manager or disable the IPSec policy service?

Thanxx Replying. No I didn’t disabled the ipsec neither enabled it. It was enabled by default on my xp sp3 system.