Internet Explorer "send link by email" causes error with COMODO active

I have determined that Comodo V3 causes an error to be generated when trying to send a link, or a page from IE. When sent from Firefox, there is NO problem.

The error is: The connection to the server has failed. Account: ‘’, Server: ‘’, Protocol: SMTP, Port: 465, Secure(SSL): Yes, Socket Error: 10061, Error Number: 0x800CCC0E

In order for this error NOT to occur, I have to set Comodo Firewall Security Level to DISABLED.

Please tell me how to adjust COMODO’s settings, or to retrain it, to prevent this issue.

have you tried putting the firewall and D+ in training mode for a bit first instead of disabling it.

I had previously put just the Firewall in Training mode (which didn’t work), so this time as you suggested, I put Firewall and D+ in Training mode.

This not only doesn’t work, it brings up no window asking what should be done with activity.

So, so far, the only thing I have found that works, is to shut down the firewall.

If the Firewall and D+ are in training mode you will get NO pop ups cause everything will be concidered trusted and learned. Can you post a screen shot of the alert?

As you can see in attachment, it is an Outlook Express error.

Strange thing about it, I send the link to myself, and the email winds up in my OE OUTBOX and sits there for 5-10 minutes, and finally it gets sent.

As stated, with FireFox browser, there is no problem. The problem has got to be a setting in COMODO, but where?

[attachment deleted by admin]

Have you tried making Outlook an email client under the firewall?

I would try it, but haven’t a clue how to accomplish that.

I have thought about uninstalling COMODO and starting over.


You can do this by a normal firewall pop-up, Treat aplication as…Email Client

But if you already have pre-existing rules you can modify them by doing this;

Comodo → firewall → Network Security Policy → Find Outlook and right; Edit;Use predefined policy;email Client


But, Doesn’t work.

There is a clue here somewhere that with IE, there is the problem; with Firefox, no problem.
I really don’t think it is OE-related, but what do I know.

And for that matter, what does MS “tech support” know? I spent 4+ hours on the phone with them (three different “techs”) before I posted here, and for the first time in my experience they totally bombed out-no help at all. All, they succeeded in doing was changing a whole lot of settings, which I couldn’t have gotten back if I hadn’t had a recent Image of my hard drive to go back to. Their support competence took a HUGE nosedive when they followed everyone else in the software business in outsourcing to India. Thanks to Terabyte Drive Image, I am back to where I was.

!ot! I spoke to microsoft support once… I got some lady that could barely understand what I was saying… But that’s another story… !ot!

Ok so, Do this for me please,

Comodo → Defense+ → Events
Comodo → Firewall → Events

If anything is being blocked, Please post a screen shot so someone can help you.

I won’t be on for a number of hours, So someone else should be able to help you :slight_smile:

Yep, as I suspected: IE blocked from sending email.
See attached PDF file.
Each event represents one attempt to send web page through IE.

[attachment deleted by admin]

Do you have IE selected as a web browser under the firewall? Go to Firewall\Advanced\Network Security Policy.


See my PDF attachment.

Also note there are six sub items under IE, and that last item regards blocking and logging all unmatching requests.

strangely enough, Firefox does not even have a predefined policy available to make it a web browser.

[attachment deleted by admin]

Of course it does. Just edit it and select it from the predefined policy’s like you did with IE.


I changed to “Trusted App” and that works.
see attach for change in App Rules.

Thanks for all the help to Vettetech and to Kyle. This Comodo is one complicated piece of software (for me anyway).

Re Firefox: a predefined policy of “Web Browser” is NOT one of the choices available presently, and that choice did not work for IE anyway.

However, maybe better to leave that sleeping dog alone.

Are you looking under the firewall policy or D+ policy. If you right click and edit Firefox from the firewall policy of course web browser is there. Select it from the predefined rules and pull it down from the menu.

You are right. These old eyes didn’t see the scroll bar for Firefox PreDefined policies. Web Browser was at end of list.

I changed to that predefined setting, and Firefox still works to send web page links.


You know what I still find a bit weird? That the blocked link from IE eventually went through anyway! In spite of the settings and the error message.