Internet Explorer and Comodo Antivirus

Hello everyone,
I’m experiencing a problem with Internet Explorer. I just installed Comodo internet security suite. And right after, when I’ve tried to run Internet Explorer it opens, but with an alert saying:

Assert in LSP
False
Failed to initialize mutex.frr=5
c:\src\googleclient\total_recall_r4_en\common\shared_memory_ptr.n:188.

And it gives the options to Abort, Retry or Ignore.
Now if I click ignore, I can use internet explore, though sometimes is crashes.
I only have Comodo Antivirus and Defense +, I don’t have it’s firewall on. If anyone thinks that they have a possible answer to this problem, any help would be much appreciated. Thank you all for your time.

  • So

Follow these 3 steps:

  • Reset IE and check add-ons: Internet Explorer - Reset | Vista Forums
  • Delete browsing history: Tools → Delete Browsing History → Delete all.
  • Reset Winsock settings: run Command Prompt as administrator and type netsh winsock reset. Restart computer and report back whether it works ok now or still not.

Hi Deadman. I followed the steps that you provided, but after I restarted my computer Internet Explorer is still showing the same pop up alert.

Assert in LSP
false
Failed to initialize mutex. Err=5
c:\src\googleclient\total_recall_4r_en\common\shared_memory_ptr.h:188

Thank you for replying. Hopefully there is another remedy for this problem.

  • So

Do you use Google Desktop?

No. I did have a Google Toolbar, but I uninstalled that. One other thing to add, Explorer even seems to freeze and crash if I go to google.com.

Well I still haven’t solved this problem. Which is weird for me because I’m usually quite good at finding solutions when my computer goes nuts. I did however find a sort of work around. If I run Internet Explorer as Administrator, the pop up alert doesn’t show up and Explorer is not unstable.
If anyone comes across the fix for this though, I would love to know. Thank you for your time and interest.

  • So

Could you post here HiJackThis log?

Hi all,
sorry for the delay. I tried installing the new IE9, but the same problem still remains. So I’m posting my system scan from TM’s HijackThis:

R1 - HKCU\Software\Microsoft\Internet Explorer\Main,Search Bar = Preserve
R0 - HKCU\Software\Microsoft\Internet Explorer\Main,Start Page = http://ca.yahoo.com/
R0 - HKLM\Software\Microsoft\Internet Explorer\Main,Start Page = http://securityresponse.symantec.com/avcenter/fix_homepage
R0 - HKCU\Software\Microsoft\Internet Explorer\Toolbar,LinksFolderName =
O1 - Hosts: ::1 localhost
O4 - HKLM..\Run: [USB Storage Toolbox] C:\Windows\UMStor\Res.EXE
O4 - HKLM..\Run: [Windows Defender] %ProgramFiles%\Windows Defender\MSASCui.exe -hide
O4 - HKLM..\Run: [COMODO Internet Security] “C:\Program Files\COMODO\COMODO Internet Security\cfp.exe” -h
O4 - HKLM..\RunOnce: [Launcher] %WINDIR%\SMINST\launcher.exe
O4 - HKCU..\Run: [msnmsgr] “C:\Program Files\Windows Live\Messenger\msnmsgr.exe” /background
O4 - HKCU..\RunOnce: [Shockwave Updater] C:\Windows\system32\Adobe\Shockwave 11\SwHelper_1151601.exe -Update -1151601 -“Mozilla/4.0 (compatible; MSIE 8.0; Windows NT 6.0; Trident/4.0; GTB6.3; SLCC1; .NET CLR 2.0.50727; .NET CLR 1.1.4322; .NET CLR 3.5.30729; .NET CLR 3.0.30729; OfficeLiveConnector.1.5; OfficeLivePatch.1.3; 697907444903; [xSP_2:92d86fee743c3506ae49edb362c0ff8d_249])” -“http://www.freeonlinegames.com/racing-games/driving-test.html
O4 - HKUS\S-1-5-19..\Run: [Sidebar] %ProgramFiles%\Windows Sidebar\Sidebar.exe /detectMem (User ‘LOCAL SERVICE’)
O4 - HKUS\S-1-5-19..\Run: [WindowsWelcomeCenter] rundll32.exe oobefldr.dll,ShowWelcomeCenter (User ‘LOCAL SERVICE’)
O4 - HKUS\S-1-5-19..\Run: [AVG7_Run] C:\PROGRA~1\Grisoft\AVG7\avgw.exe /RUNONCE (User ‘LOCAL SERVICE’)
O4 - HKUS\S-1-5-20..\Run: [Sidebar] %ProgramFiles%\Windows Sidebar\Sidebar.exe /detectMem (User ‘NETWORK SERVICE’)
O4 - HKUS\S-1-5-18..\Run: [AVG7_Run] C:\PROGRA~1\Grisoft\AVG7\avgw.exe /RUNONCE (User ‘SYSTEM’)
O4 - HKUS.DEFAULT..\Run: [AVG7_Run] C:\PROGRA~1\Grisoft\AVG7\avgw.exe /RUNONCE (User ‘Default user’)
O9 - Extra button: @C:\Program Files\Windows Live\Companion\companionlang.dll,-600 - {0000036B-C524-4050-81A0-243669A86B9F} - C:\Program Files\Windows Live\Companion\companioncore.dll
O9 - Extra button: @C:\Program Files\Windows Live\Writer\WindowsLiveWriterShortcuts.dll,-1004 - {219C3416-8CB2-491a-A3C7-D9FCDDC9D600} - C:\Program Files\Windows Live\Writer\WriterBrowserExtension.dll
O9 - Extra ‘Tools’ menuitem: @C:\Program Files\Windows Live\Writer\WindowsLiveWriterShortcuts.dll,-1003 - {219C3416-8CB2-491a-A3C7-D9FCDDC9D600} - C:\Program Files\Windows Live\Writer\WriterBrowserExtension.dll
O9 - Extra button: Send to OneNote - {2670000A-7350-4f3c-8081-5663EE0C6C49} - C:\PROGRA~1\MICROS~3\Office12\ONBttnIE.dll
O9 - Extra ‘Tools’ menuitem: S&end to OneNote - {2670000A-7350-4f3c-8081-5663EE0C6C49} - C:\PROGRA~1\MICROS~3\Office12\ONBttnIE.dll
O9 - Extra button: Research - {92780B25-18CC-41C8-B9BE-3C9C571A8263} - C:\PROGRA~1\MICROS~3\Office12\REFIEBAR.DLL
O9 - Extra button: PokerStars.net - {FA9B9510-9FCB-4ca0-818C-5D0987B47C4D} - C:\Program Files\PokerStars.NET\PokerStarsUpdate.exe
O11 - Options group: [ACCELERATED_GRAPHICS] Accelerated graphics
O18 - Protocol: skype4com - {FFC8B962-9B40-4DFF-9458-1830C7DD7F5D} - C:\PROGRA~1\COMMON~1\Skype\SKYPE4~1.DLL
O18 - Protocol: wlpg - {E43EF6CD-A37A-4A9B-9E6F-83F89B8E6324} - C:\Program Files\Windows Live\Photo Gallery\AlbumDownloadProtocolHandler.dll
O20 - AppInit_DLLs: C:\PROGRA~1\Google\GOOGLE~1\GOEC62~1.DLL C:\Windows\system32\guard32.dll
O20 - Winlogon Notify: avgwlntf - avgwlntf.dll (file missing)
O22 - SharedTaskScheduler: Component Categories cache daemon - {8C7461EF-2B13-11d2-BE35-3078302C2030} - C:\Windows\system32\browseui.dll
O23 - Service: Ati External Event Utility - ATI Technologies Inc. - C:\Windows\system32\Ati2evxx.exe
O23 - Service: COMODO livePCsupport Service (CLPSLS) - COMODO - C:\Program Files\COMODO\COMODO GeekBuddy\CLPSLS.exe
O23 - Service: COMODO Internet Security Helper Service (cmdAgent) - COMODO - C:\Program Files\COMODO\COMODO Internet Security\cmdagent.exe
O23 - Service: Crypkey License - CrypKey (Canada) Ltd. - C:\Windows\SYSTEM32\crypserv.exe
O23 - Service: FLEXnet Licensing Service - Acresso Software Inc. - C:\Program Files\Common Files\Macrovision Shared\FLEXnet Publisher\FNPLicensingService.exe
O23 - Service: LightScribeService Direct Disc Labeling Service (LightScribeService) - Hewlett-Packard Company - c:\Program Files\Common Files\LightScribe\LSSrvc.exe
O23 - Service: MBAMService - Malwarebytes Corporation - C:\Program Files\Malwarebytes’ Anti-Malware\mbamservice.exe
O23 - Service: NMIndexingService - Unknown owner - C:\Program Files\Common Files\Ahead\Lib\NMIndexingService.exe (file missing)

Thank you for your time.

  • So

Fix this item in HiJackThis:

  • O4 - HKLM..\RunOnce: [Launcher] %WINDIR%\SMINST\launcher.exe

Also, you can run MBAM and Hitman Pro; just to make sure this issue isn’t related to malware. Did you ever have installed AVG 7.0 on your PC? I’m asking you that because it is still present in registry and tries to load itself on startup. Run the AVG Remover.

I fixed the item:
•O4 - HKLM..\RunOnce: [Launcher] %WINDIR%\SMINST\launcher.exe
Also, I ran the AVG remover, thanks I was trying to figure out how to get rid of that. And yes I have MBAM and run it often, so I don’t believe malware or spyware is the problem.
After doing what you said, the pop up alert still remains. It just doesn’t want to leave lol. Again I appreciate all the help. And if I do come across a solution somehow, I will be sure to post it.

  • So