Internet Connection Sharing

Hi!

I installed the .268 version. When my ICS wouldn’t work, I checked in the forum and read that that’s normal for the .268. So I used the patch to update to .276… but the ICS is still not working.
I also deleted the Windows Updater Application in Defense+ (I found that somewhere in the forum), that didn’t help either…

File sharing works by the way, it’s just the Internet that I can’t access from the other computers…

Can somebody please help me?

Alexandra

Hello,

I also have the same problem: with the previous version, all worked fine. From version 3 Comodo does’nt recognize Internet Connection gateway (ICS) in a Lan environment (directoryes sharing instead is well).

I suggest its possible that what both of you don’t understand is that the windows updater rules must be deleted using the group policy editor found in defense plus. ( Or at least thats how I did it )

You should also check to see you have defined your lan by the same name in network zones, and then use the stealth port wizard. ( I defined my lan as a range of ip addresses from 1921.68.0.1 to 192.168.0.254 )

And at least in my case, then and only then will you get a set of pop ups allows regarding networking and ICS.

And then after allowing the pop ups, like magic, ICS worked for me.

Hi!

Thanks for trying to help, Osage!!

I have the same network zone on all computers and I deleted the windows updater rules under Defense+ → advanced → computer security policy. I have no ICS… :frowning:

Osage, did you also update from .268 or did you do a complete reinstall (or did you start right away with a higher version)?

Alexandra

You need a clean install for the new rules. The patch does not add the newer rules, only updates components.

Hi!

Thanks for your answer, Coolio10…

So I just did a clean install of the .276 version (uninstalled the previous version, rebooted, made a registry clean-up, installed the new version), then I deleted the windows updater entries in firewall and defense+ (as mentioned elsewhere in the forum), and… still no ICS (but file sharing still works) :frowning:

Any other idea? Which rules and applications are important for the ICS?

By the way: before I had the 2.4 version and ICS was working. But I hate the idea of going back to an older version…

Alexandra

Ok, something strange was going on…

As I mentioned before I used ICS with 2.4 without problems and I didn’t change anything besides installing 3.0.

But when I checked my Internet connection, I noticed that it was no longer shared!! I don’t know if Windows changed that during some recent update or if it is related to uninstalling and installing Comodo. Doesn’t matter… I was all happy (and somewhat embarrassed that I didn’t check that earlier) and activated it again, but… nothing…

Then I noticed blocked firewall events from my other computer to the ICS server for svchost. So I added a rule for the svchost application to allow incoming IP from my home network to any IP and that finally did the trick.

Can someone please tell me if that is a safe thing to do?

Thanks,
Alexandra


To belatedly answer your question, a complete clean install of the 276 version. Including deleting the
comodo directory in program files. Worked first pop out of the box for me with ICS and everything else up and running.