"Internet Connection Sharing" blocked as "Windows Operating System" [Resolved]

I’m trying to connect my Xbox 360 through Windows Internet Connection Sharing. It’s worked happily enough with CIS the last time I tried it with CIS 3.8 (or maybe 3.5, not sure) :frowning:

Obviously I have the ICS server option enabled.
I also used the “Define a new trusted network” to create rules for the 192.168. range that it uses.
And since it’s being blocked as “Windows Operating System” I don’t believe that it can be the fault of any rules I have set.

Maybe this is down to the same cause as the “Windows Operating System” blocks I get with DCC connections in mIRC ? Which I previously posted about and will keep mentioning -_-

[attachment deleted by admin]

Did you make the Network Zone trusted using the Stealth Ports Wizard? If not go to Firewall → Common Tasks → Stealth Ports Wizard → choose “Define a new trusted network, stealth my ports to everyone else” → Next → Choose “I would like to trust an existing My Network Zone”–> choose you local network from the drop down box at the bottom → Finish.

Now you should be good to go.

As I stated in my first post, I’ve already done that.

The only other block rule I have besides the ones created by CIS in the Global section is for port 137 of “System”.
I have the firewall set to “Custom Policy Mode” with full alert settings.

[attachment deleted by admin]

Ok, I found a way to make it work.
I have disabled the “Comodo Internet Security Firewall Driver” on the socket that I use for ICS, leaving it enabled on the other that is for the internet access.

I’m less than entirely convinced this should have been nessecary, but at least it works now.
I had done this previously and forgot that reinstalling Comodo will have reinstated it enabled.

You also need the “Allow IP out from IP Any to IP Any where Protocol is IP Any” to allow for outgoing traffic.

Look at my Global Rules for reference.

[attachment deleted by admin]

Oof, no thankyou. Might as well not have an application level firewall installed if you’re going to add a rule like that :o

Hi!

I use Comodo firewall 3.0 because with the versions 3.5 and 3.8, i’m unable to share my connection (bug?)

With the 3.0 version, I have set this rule in “Advanced network Policy”=>“Global rules”=>“Allow all incoming request if the sender is in [Local 192.168.0.1]” and “Allow all outgoing request if the sender is in [Local 192.168.0.1]”
My networkzone from 192.168.0.1 to 192.168.0.255 is called [Local 192.168.0.1]

I have another rule for blocking all incoming/outgoing connections from 192.168.1.2-192.168.1.254 because it’s an untrusted network but 192.168.1.1 is the router.

Tell me please if this rules work with v3.9.

P.S: Sorry for my english

When you try the 3.8 and 3.9 do you start with a clean installation? I mean you didn’t import the configuration from 3.0?

Try adding 192.168.01.1 to your [Local 192.168.0.1] zone. When that doesn’t help can you show your Global Rules of 3.8 or 3.9 with a screenshot?

Thanks a lot, that solved the issue for me too (Comodo ver. 3.9.95478.509).
I installed Comodo a few days ago on Win XP64.

I had also applied as the first step the canonic solution (go to “Security->Tasks->Wizards->Add a trusted zone” and define your network as your Trusted Zone.) and it didn’t work:

very strangely I could ping from my second machine to an outern-world IP, but Firefox could not open any web site (configured for direct connection, no proxies, and of course network configuration implying the first machine as a gateway).

If I kept my second machine and Firefox configuration in the very same state and rebooted my first machine to Win XP 32 bit with another firewall (switched to intermediate security level, not fully stealth) then Firefox on the second machine could open any web site.

I wonder if now my second machine is protected by Comodo, actually the anything OUT anything IN rules are not reassuring, I’ll have to keep learning, I don’t know if this issue is a bug of this version, anyway Comodo looks like a powerful and flexible tool.