Internet Connection Lost Immediately Following Install

I just downloaded and installed the free version of Comodo on my 64-bit Windows 7 laptop. I set the security level to Maximum in the installer, and finished the install. The minute the program loaded up, connectivity betwen my router and my wireless adapter on my laptop was lost. It’s labeled as having ‘Limited Connectivity’, and when I run the troubleshooter, it says ‘There might be a problem with the driver for the Wireless Network Connection Adapter’.

I went to the wireless adapter in the Device Manager and rolled back the driver, but it didn’t fix anything. I googled the problem on my other computer (which can still connect to the internet, and I am on right now) and on another forum it said to reset the IP stack and Winsock catalog, so I did these commands in cmd.exe:

netsh int ip reset
netsh winsock reset

Then I rebooted my computer. When it booted up, the internet still wouldn’t connect. I did an ipcofig /all, and my wireless adapter didn’t even appear on the list.

I uninstalled and reinstalled Comodo under a weaker security level, and the internet still won’t connect.

I also tried uninstalling the wireless adapter and rebooting, which reinstalled the adapter. No luck, The problem remains.

Installing comodo really ■■■■■■■ up my internet connection, and nothing seems to be helping. Please help!

Do you have ARP cache protection enabled? Then please disable it for now. It has a bug and it will be fixed with an update tomorrow.

When in that corner of CIS see if disabling “Block fragmented IP datagrams” helps or not.

Also follow No network connection after using Stealth Ports Wizard (DHCP Broken) to see if that helps to fix your problem.

Ok. I reinstalled Comodo and went to the settings. ARP cache protection was disabled, so that wasn’t the issue. I also unchecked ‘Block fragmented IP datagrams’, and that didn’t do anything either.

I then went into the link you posted and went through the steps and made the new Global Rule to try to get the DHCP working again. I followed all the steps, but when I went to the CMD.exe and tried to do an ipconfig /renew, and I got the message “This operation failed as no adapter is in the state permissible for this operation.”

I did an ipconfig /all after all of that, and DHCP is still disabled. The wireless adapter still isn’t recognized.

I also went into my wireless network adapter properties, and under IPv6 and IPv4 the ‘Automatic’ choices are set on both of them. So, that isn’t the issue either.

Any other suggestions? I use this laptop for work, and it’s crucial that I have it fixed before tomorrow morning. I was just trying to set up a firewall. :frowning:

Here is another basic you try. May be left overs of previously installed security programs are in the way. Try using removal tools for those programs. Here is a list of removal tools for common av programs: ESET Knowledgebase .

Otherwise do a Google search with terms “removal tool” and * name of product or vendor*.

dadude,

If you still have a problem with your connectivity after doing everything Eric suggested you could try the following:

  1. Disconnect from your wireless.

  2. Completely uninstall CIS. When it’s finished you will be asked to reboot. Do so.

  3. Since you rebooted you probably will have to disconnect from your wireless again.

  4. After uninstalling CIS perform a cleanup using the little app from here: Comodo Forum. This is a portable little app which means all you need to do is to run it. Don’t reboot yet. You will reboot in the next step.

  5. I know you already uninstalled and reinstalled the wireless driver but repeat this step anyway… do exactly what you did the last time (uninstall - reboot - reinstall the driver). Always use the latest available driver. Use previous versions of drivers only in case when the newest version doesn’t work for you.

  6. After reinstalling the wireless driver check if there is connectivity. If there is, disconnect again.

  7. Install the CIS. After the installation of CIS is complete it will ask you to reboot. Do so.

  8. After the OS finishes loading the CIS should detect that there is a network present (that should be your wireless network). Give it a name and click OK.

That should be all you have to do.

I tried everything mentioned in the last two posts exactly as posted, and I had no luck.
Any other suggestions?
I’d be pretty upset if I had to format my hard drive because of Comodo.

Hello dadube,

maybe you could try this : go to FW > Stealth Ports Wizard > choose the first option and define a new trusted zone which will unclude you wireless adaptater.

Sometimes it happens that you can’t connect to the internet after uninstalling, using the unofficial clean up tool or trying a manual deinstallation. Then the Inspect driver is still present and needs to be uninstalled.

How to uninstall the CIS firewall driver when it stays present? Look up the properties of the network connection, select the Comodo Firewall driver and uninstall it. See the attached image.

Now reboot back into Windows and try again.

Just tried opening a stealth port, it didn’t work.

The Comodo driver was still present on my Local Area Connection, so I uninstalled it, but it wasn’t present on my wireless adapter. I rebooted after unintalling, and I still have the same problem.

Any other ideas? I can’t believe I am having these problems.

dadude,

Since everything else failed did you try System Restore? Windows 7 should create a restore point before installing CIS… mine did. Unless you turned off the System Restore the restore point should be there.

Well, I was hoping to avoid a system restore, but I went ahead and did it. Restored to a point last week before I went near Comodo. Everything is back to normal.

I have to say, I’ve never come across a program that was terrible enough to actually sever the connection to a piece of my hardware like that. Especially using the default settings. Congrats Comodo, you’re the worst program ever. Time to go write some reviews/warnings on this ■■■■.

Thanks for the help anyways, guys.

Zonealarm, here I come.