Internet Connection Lost Because of Firewall [Resolved]

Every time i restart or shutdown then turn on my computer, my internet says there is limited or no connectivity. If i disable the firewall and reconnect my wireless usb adapter, my internet works fine. I’ve tried adding my ip as a trusted network, but the same thing still happens. What should i do? Thanks in advance.

What is your CFP version & OS?

Josh

I have version 3.0.22.349 and Windows XP Media Center.

Does WinSoc Solve your problem? You need to restart your PC after use. Please also make sure thier are NO other conflicts with other security apps on your pc.

Josh

I will try WinSoc as you said. There should be no conflicts with other security apps because I only have CFP and ESET NOD32 AntiVirus installed on my computer.

I tried your solution with no success (:SAD)
The only time my internet works is with my firewall disabled…

Hi dudefromjapan,

Is anything related (compare by time) appear in the log (view firewall events)?

I attached a screenshot of my firewall events.

[attachment deleted by admin]

make sure svchost.exe is not blocked in network security policy or computer security policy

Do you mind telling me how to do this? When I go to network security policy to edit it, CFP tells me that i need to use a “Predefined Firewall Policies” window to edit this item. Sorry I am not that familiar with CFP. Thanks again.

I guess CFP is blocking dhcp reply that’s why you get limited or no connectivity. To fix this simply create rule to allow incoming dhcp reply for svchost.exe.

Doesn’t that look more like a lease renewal request, since the client already has an IP? I attached a Wireshark log of a typical DHCP setup. If allowing the previously blocked UDP doesn’t fix the problem, could be running into https://forums.comodo.com/empty-t19817.0.html . To allow it, just make a rule for svchost.exe
allow/udp/out/any/68/any/67 and see if it starts working. Don’t know what predefined policy you are using already, but you can go to the application, edit the policy to “custom/copy from” whatever predefined you are using, then add a rule as necessary.

[attachment deleted by admin]

Do I go into “Predefined Firewall Policies” to create a new rule to allow svchost.exe? Sorry I’m such a noob at this :confused:

To create an outgoing rule go to Firewall>Advanced>Network Security Policy. Under application Rules, look to see if you have svchost listed. If You have a block rule, change it to outgoing only and see if that helps.

Some people like a tighter rule for svchost, but first just check your rules to make sure it’s not blocked.

I have posted this several times. Here it is again and works for me just fine.

[attachment deleted by admin]

Yep, you are right Ed. Thanks for correcting me :slight_smile:
Will edit my previous message.

Thanks guys I was able to create a rule to allow svchost.exe and now my internet works fine while my firewall is active. (:WAV)

Ok, good you solved problem. Thread will be closed now. If issue returns PM any online moderator to open.