Internet Connection Detected Last in System Tray

A. THE BUG/ISSUE: No Internet Connection for AV (mbam Pro Update) at Startup.

  1. What you did: Replaced Uninstalled Zone Alarm + their AV, Installed Comodo, Avira.
  2. What actually happened or you actually saw: The Internet Light on the Modem does not light up(solid green) until after these are loaded: System Tray Icons load, MBAM, Secunia, Host server, Avira, Hostsman, Comodo, then the Internet Connection is detected, and select “I am at Home” on Comodo Screen.
  3. What you expected to happen or see: Internet Connection first, as it did with my previous setup of ZA Firewall.
  4. How you tried to fix it & what happened: Nothing yet.
  5. If a software compatibility problem have you tried the compatibility fixes (link in format)?: N/A
  6. Details & exact version of any software (execpt CIS) involved (with download link unless malware):
  7. Whether you can make the problem happen again, and if so precise steps to make it happen: Restart Computer.
  8. Any other information (eg your guess regarding the cause, with reasons):

B. FILES APPENDED. (Please zip unless screenshots).:

  1. Screenshots of the Defense plus Active Processes List (Required for all issues):
  2. Screenshots illustrating the bug:
  3. Screenshots of related CIS event logs:
  4. A CIS config report or file: who accepts cfgx file ? Imageshack doesn’t !
  5. Crash or freeze dump file:
  6. Screenshot of More~About page. Can be used instead of typed product and AV database version:

Edit by Dennis2: I removed the spam like notification that your image was uploaded to a well known image sharing site


  1. CIS version, AV database version & configuration:
  2. a) Have you updated (without uninstall) from a previous version of CIS: No
    b) if so, have you tried a clean reinstall (without losing settings - if not please do)?:
  3. a) Have you imported a config from a previous version of CIS: No
    b) if so, have U tried a standard config (without losing settings - if not please do)?:
  4. Have you made any other major changes to the default config? (eg ticked ‘block all unknown requests’, other egs here.): No
  5. Defense+, Sandbox, Firewall & AV security levels:
  6. OS version, service pack, number of bits, UAC setting, & account type: Xp/Pro SP3 32 bit Admin Acct
  7. Other security and utility software currently installed: MBAM, Secunia, Host server, Avira, Hostsman, Comodo
  8. Other security software previously installed at any time since Windows was last installed: AVAST, MSE, ZA without their AV
  9. Virtual machine used (Please do NOT use Virtual box)[color=blue]:

From the information you have given I am not clear whether this is a bug/issue. I think this is probably happening because you are running too many security programs and may not have eliminated potential conflicts between them. Here is a FAQ that will help you: Making other security programs work with CIS.

For the moment I will transfer you to help so you can work through this issue with users and mods in this forum and hopefully resolve it. I hope that is OK. It will help if you ca make clear where you are seeing the modem light (on the physical modem or computer system tray?) and what that particular light is supposed to signify, and what the modem is (USB modem or router?).

Please ask any mod to move this report back to the bugs forum if it becomes clear that it is a bug/issue.

Problem Clarification: Before installing Comodo / Avira (Used Zone Alarm / AV), connection to the Internet would be established prior to MBAM attempting update. Now that I switched to Comodo / Avira, the MBAM update fails (usually) ! This morning is the 1st time the update actually worked in the past week. What has changed is that the Internet connection seems to be getting established last, and I now get a balloon in the system tray saying Internet is now connected, after everything else has loaded. Previously all lights on the DSL modem (Power DSL Ethernet Internet) would be green and the MBAM update would work each and every startup. Now, (Power, DSL, Ethernet) are green, Internet is not lit up, MBAM tries to update, but fails
because the Internet connection has not been made. I will continue to watch this over the next week or so to see what transpires with the MBAM updates, and post my findings. It is just too coincidental that with the new security I installed, the Internet connection is established lastly in the sequence of startup events.l

Thanks for the clarification. As this is an ethernet modem, not a USB modem, I am having trouble understanding how CIS could affect it. An ethernet modem is like a separate computer, dedicated to the comms function. Often it runs a variant of Linux! The modem/router logs on independently to your ISP (Internet Service Provider) broadband service and in turn delivers that service to PCs attached to it’s ethernet ports. It should still log on to the ISP, and show the green light, if the PCs involved have their internet access blocked by a software firewall.

From your description I think that the PPP (Point to Point Protocol) connection is not being established by your modem. This is most likely caused by the log-on credentials being incorrect, incorrect modem settings, or by ISP failure. It can also (less commonly) be caused by a poor DSL signal - this can be just good enough to create a feeble DSL connection, but poor enough to corrupt the PPP log-in. (Some of this can vary internationally, so I hope this is correct in your country of origin, I live in the UK)

So I’d start by checking router/modem settings and then, if correct and the problem persists, get on the blower to your ISP.

Hope that helps a bit, best wishes