Internet button on keyboard doesn't work with Comodo Dragon

I have a internet shortcut key on my keyboard and CD is set to my default browser, but when i press the button it does nothing. When IE or chrome was set to my default, the button works.

How do i fix this? I’m on windows 8.1 x64 enterprise.

I too have such a button and was in pursuit of a way to fix it, so far I haven’t seen a fix for this, which makes me sad. :-\

do you think it is a keyboard problem? Because i have CD on another computer, and the button works. That keyboard was Digital Media Keyboard 3000

Does that computer also have Windows 8.x? Also, could you try connecting your keyboard to the other computer and see if it opens or not?

I guess different keyboards could use different methods of opening the browser… Either way my Ducky Shine 3 can’t open CD on my Windows 8.1 64bit computer.

My guess is that Comodo Dragon is at fault here since Google Chrome opens with the key.

Anyway here is my thread about it if you are interested:;msg701418#msg701418

k i try the other computer’s keyboard on my current computer (windows 8.1) and it does not work. I try my current keyboard on my other computer (windows 7) and it works.

so it might be a windows 8 problem. But i think Comodo can fix this. It just needs to be more known.

I’m certain Comodo could fix this, question is whether they will… Nothing will be done as long as it’s only in the help section, these don’t get exposed to the developers I don’t think, rather we’d have to make a bug report.

Edit: Made bug report here:

Edit 2: Okay the universe is trolling me now, during that bug report I tried to start Comodo Dragon with the internet button several times, probably upwards 20… now when the bug report is submitted it somehow magically works after pretty much half a year… Ahahah good one universe, you had me there… giving me an issue for over pretty much half a year and then when I make a bug report about it then obviously it starts working for me… Ahahaha good one! >:(
I’m guessing you still have the issue though, I recommend you post in the bug report and say you have the issue too.

Update to this, I’ve found a workaround.

Basically I fixed this using AutoHotKey, all you need to do is create a script that says Browser_Home::Run Dragon

I’ve compiled the script as a AutoHotKey executable and attached the file to this post if you want to try it, I’ve tried it myself and it’s working for me.

The drawback with this is the fact that you need to have a process running at all times for it to work, you can manually add it to the start up folder if you want it to start with Windows.

[attachment deleted by admin]