Intermittent black Screen on Login. [M110]1[v6]

A. The bug/issue

  1. What you did: Started my computer and Logged into Windows.
  2. What actually happened or you actually saw: After logging in, instead of arriving at the Metro start page I was put at a Black screen with just the cursor, I could move it around. CTRL + alt + Del worked, however task manager didn’t and re-logging didn’t fix it.
  3. What you expected to happen or see: A normal login? Arriving at the metro start screen.
  4. How you tried to fix it & what happened: Un-installed and waited for a later release, not much happened =/
  5. If its a software compatibility problem have you tried the compatibility fixes (link in format)?: I don’t know?
  6. Details & exact version of any software (execpt CIS) involved (with download link unless malware): I don’t know! ;_;
  7. Whether you can make the problem happen again, and if so exact steps to make it happen: It happens now and then, often it doesn’t happen again the same day if you successfully get in. So in the morning I start my computer and have to make a hard-reset maybe 2 to 3 to 10 times before it works and after I get in, it works.
  8. Any other information (eg your guess regarding the cause, with reasons): I know I don’t really have the information to make a complete bug report, However I want to say that this has been going on for two different systems so I don’t think it was specific to the hardware in my old computer.

I had this problem on my old computer too, and then I had made a completely clean Windows install and installed CIS 5.12 and got the problem, as well as with CIS 6 beta. And now I’m getting the same problem with my new computer.

If I un-install CIS the problem stops and I never get it again until I install CIS again, notable is that it liks to happen whenever the f**k it wants to, so it might happen during the morning for 10 reboots in a row, or it might not happen at all for several days. But I do know that if I un-install CIS then it won’t happen again until I install it again.

Also something worth adding is that the Windows Event Viewer had some information that might be relevant:
“Event 6003, Winlogon
The winlogon notification subscriber was unavailable to handle a critical notification event.”
“Event 6000, Winlogon
The winlogon notification subscriber was unavailable to handle a notification event.”
“Event 6000, Winlogon
The winlogon notification subscriber was unavailable to handle a notification event.”
“Event 6003, Winlogon
The winlogon notification subscriber was unavailable to handle a critical notification event.”

B. Files appended. (Please zip unless screenshots).

  1. Screenshots of the Killswitch Process Tab (see Advanced tasks ~ Watch Activity. Required for all issues): Not possible when the computer is in that state.
  2. Screenshots illustrating the bug: Not possible =/ I can take a picture from my cellphone whenever it happens again.
  3. Screenshots of related CIS event logs:
    Not sure if it’s related but I took a screenshot of CIS log during the time this happened.
  4. A CIS config report or file.
    … For some reason I can’t export the configuration, clicking save does nothing =S
  5. Crash or freeze dump file:
    I don’t think I got any
  6. Screenshot of More~About page. Can be used instead of typed product and AV database version.

C. Your set-up

  1. CIS version, AV database version & configuration used: CIS 6.0.260739.2674, database 14602, Proactive configuration but I changed things myself.
  2. a) Have you updated (without uninstall) from from a previous version of CIS: Yes
    b) if so, have you tried a clean reinstall (without losing settings - if not please do)?: Sort of but I’ll try it again.
  3. a) Have you imported a config from a previous version of CIS: No.
    b) if so, have U tried a standard config (without losing settings - if not please do)?:
  4. Have you made any other major changes to the default config? (eg ticked ‘block all unknown requests’, other egs here.): I’ve made some changes myself, will post configuration in screenshot.
  5. Defense+, Sandbox, Firewall & AV security levels: D+= Paranoid, Sandbox= Disabled, Firewall = Custom Ruleset, AV = Uhm… Enabled?
  6. OS version, service pack, number of bits, UAC setting, & account type: Windows 8 64 bit OEM, UAC is completely off and the account is the one and only account, also administrator.
  7. Other security and utility software currently installed: TrueCrypt?
  8. Other security software previously installed at any time since Windows was last installed: Windows Defender (Built-in), CIS 6 Beta, CIS 5.12.
  9. Virtual machine used (Please do NOT use Virtual box): None

[attachment deleted by admin]

Very sorry you are having this problem

Thanks very much indeed for your report in standard format. Just holding it here until we decide whether to create separate child boards for 6.0

I or another mod will try t help you out with your issues as soon as possible. We’ve all been a bit surprised by this update, apols.

Best wishes

Mouse

Thank you very much for your report in standard format, with all information supplied. The care you have taken is much appreciated by Comodo, and will increase the likelihood that this bug can be fixed.

Developers may or may or may not communicate with you in the forum or by PM/IM, depending on time availability and need. Because you have supplied complete information they may be able to replicate and fix the bug without doing so.

Many thanks again

Mouse

How frustrating, very sorry you are having this problem.

My guess is that it may be the OS going in and out of sleep mode which is interacting with CIS in some unhelpful way? Could you try turning sleep/hibernation off for a few days and report back on whether it occurs?

Also are you getting elevated privs alerts for the files in the logs or are they maybe in unrecognised files?

Please report your export problem as a separate bug

Many thanks

Mike

Unless clicking “Shut down” in the “right charm > Settings > Power” menu then I don’t think I’m going into sleep or hibernation. However I also have Sleep turned to “Never” in the Power options.

I’m not sure whether or not I’ve given them elevated privileges, when I’m in the black screen thingy with my cursor I don’t get any CIS alerts. I don’t have any files in the Unrecognized Files… container?

Will do.

Uhm… sorry that didn’t go as I planned =/ I thought there were a modify button but apparently not. What I meant to say was: “Oh wooow I’m stupid, for the problem with not being able to export the config… I forgot to put in a file name! <_< Now it saved, should I attach it in a zip file and upload it?” Sorry for the… triple posting…

Yes that would help, thank you very much. And don’t worry a couple of my bug reports I could have solved myself if I had looked at the next tab…

Could you take a picture of your all your processes as seen in Killswitch when running normally, and add a note to say that’s what you have done.

That will give Devs the best info, and me some info which may help to suggest a work around

Best wishes

Mouse

Perhaps I should note that it has only happened once after installing the current version which happened a bit before the bug report though it happened two times in a row.

So I should just take screen shots of KillSwitch right now? Adding them to this post so don’t know why I even ask. ^-^‘’
Added a screenshot of both top and bottom of the scroll since it’s too many for one screenshot. Also added the config in a zip.

[attachment deleted by admin]

Those were very useful.

If it only happened in this version just after you first installed it may be a program running with insufficient privs, which has now been made safe.

Two that stand out for causing problems in previous or current versions are Steam and Start8 (or rather I tried installing CIS 6.0 with Start7 installed, whereon the computer entered castors-up mode). Other frequent causes are graphics or utility drivers.

But both Steam and Start8 are running trusted or as installers now, so you may be OK.

Have you any idea what auinstallagent is?

Incidentally does start8 do all start7 did? Seemed from the site hat it was a cut down version but maybe not.

Best wishes

Mouse

No, it’s not the only version doing it.

Previously I had a computer with:
Motherboard: Asus Sabertooth x58
CPU: Intel i7 970
GPU: Asus GTX 560TI
RAM: 12GB
OS: Windows 8 Consumer Preview and later Windows 8 Release Preview

And on that computer I had the same issue, with both CIS 5.10 consumer preview beta, CIS 5.12 and CIS 6 beta, during the release preview I had the same problem with CIS 5.12 and CIS 6 beta.

Now I have:
Motherboard: Asus Sabertooth Z77
CPU: Intel i5 3570K
GPU: 2 x Gigabyte GTX 670 (SLI)
RAM: 16GB
OS: Windows 8 OEM

And I got the same problem with CIS 5.12, CIS 6 beta and now once with CIS 6 final.

I don’t know if Start8 works or does the same things as Start7 did/does since I don’t really know what Start7 is and when I google it I only get something called Startmenu7. Start8 has only been on my system recently though and was not present at my earlier setup.

Over the course I’ve upgraded the graphics drivers quite a few times, I don’t know if that is the issue but if it’d stand between upgrading graphics drivers and having CIS installed (if that would be the problem I mean) then I’d choose upgrading graphics drivers.

I don’t really know what the AuInstallAgent is however I found this link: Windows All-User Install Agent - Windows 8 Service - batcmd.com

However after looking at the Event Viewer some more I can see that the errors shown in the first post about AuInstallAgent occurs at pretty much every login, and for some reason it also says that shutdown success is false even though I shut down my computer correctly. -shrugs-

If you want we can put this issue on test sort of, I mean that I’ll take maybe 10 days and see if it happens again then report my findings here, because perhaps it was just a one time thing and there isn’t really an issue?

Because I remember it was quite more frequent on my older setup than it is now, on my old setup it would happen each and every morning after installing CIS however now on my new setup I only got it that one time before posting this bug report.

IF it happens again and you want to take a closer look, I could allow you to use something like Teamviewer to look around, I’d dismount my external harddrives though since that’s kind of private.

That makes sense, and thanks for looking into things so thoroughly. I’m guess that it may be graphics drivers, if it is there are ways of sorting out conflicts. What happens is when they update (auto or otherwise) some of the new files may be unsigned, and since they start early CIS can have trouble giving alerts etc. After a while they get on the servers and CIS manages a lookup.

Devs or QA will contact you if they wish to check things out with Teamviewer or equiv.

And yes I did mean StartMenu7. Start8 is referenced on their web site, I think, so maybe the same guys. Thanks for looking into it will install myself.

Best wishes and thanks again

Mouse

Alright, I’ll report back in 10 days (Sunday December 30th 2012) with my findings.

Start8 is developed by Stardock and Startmenu7 seems to be developed by “OrdinarySoft” if you go by the copyright at the bottom of the page.

Thanks much appreciated

Must try Start8

Mouse

Huge progress, couldn’t wait 10 days to report this!

My logbook so far

Friday December 21st 2012 12:37: Started just fine.

Friday December 21st 2012 23:20: Black screen, huge progress.

Now the thing is, before I didn’t have KillSwitch replace my TaskManager, hence when I pressed ctrl + alt + del and then taskmanager, that didn’t do squat. However now when I had it changed to KillSwitch, it actually ran so through there I executed explorer.exe and poof I now have an interface.

And it wasn’t until I had executed explorer.exe that things from autostart started loading, for example steam and Spotify. However there is one thing missing from the tray bar… CIS. And there is no widget to be found either! However when I look in killswitch cavwp.exe and cmdagent.exe are running which means CIS is present.

I haven’t done anything after that except starting chrome and making this post, so if there are any logs etc that you want I can supply… if I am given the instructions to where they can be found!

Actually there are more programs than just CIS missing from the Tray bar, I guess some programs actually started before explorer.exe was started hence they don’t show up now afterwards. (If programs are already running when explorer.exe is started, then they won’t show up in the tray menu.)

I got a video of it too, sorry but I had to upload it to SkyDrive first and in the process of that it is heavily compressed hence sort of bad quality. =/

Well it is getting late here so I’m going to bed now, will be back tomorrow to check for replies.

Sorry Sanya, will have a look at your posts now.

Mouse