Interesting product: Self-destructs after an update

Got back from vacation, booted up the computer, got a message that Commodo had an update, did the update which required a reboot, and now Commodo is completely disabled. I cannot enable any of its functions. Application monitor is OFF. Component monitor is OFF. Network monitor is OFF. And application behavior analysis is OFF. Popups appear over its tray icon telling me that Commodo functions are disabled which I already knew. What’s their suggestion? Reinstall the product. Oh yeah, like that is doable considering that the update which will have to reexecuted after a new install so it would self-destruct again.

Commodo makes a big deal about it being fortified against being disabled by malware. Apparently it never considered that it would disable itself. Considering all the pleas at their site and in the forums to promote their free product(s) and all the problems reported in the forums, having it self-destruct is probably a blessing in disguise in now I will have to find a more reliable product.

Bye bye. Good concept. Definitely needs LOTS of more work; however, I’m not into being an unpaid and uninformed beta tester for Commodo. I don’t have time right now to figure out their bugs.

Did you try to reboot again?
And what other programs are you running, security apps?

I have been having the same problem myself ever since I started using Comodo firewall.
Rebooting doesn’t seem to work either. I have uninstalled and re-installed a number of times .
I have pretty stringent security settings (CIS Windows Benchmark) and wonder if this is causing the program to turn off (I am unable to turn it on in the various monitors)

I will watch this space for any possible solution. Even though the updating problem is frustrating I find that the overall benefits of the program are desireable and at present am denying updates and am downloading the program at regular intervals rather than uninstalling then re-installing - this way I am getting an updated program without the daily hassle

                                                                                                  cheers & beers - Wayne

I’m not familiar with CIS Windows Benchmark, but that could be the issue. Do you have a link?

I too am having trouble since the update. It is clearly a bug in the software: it will not let me enable the “Turn On” radio buttons in the various tools!

I can’t imagine how this could have anything to do with other security software. Other software (such as my McAfee “Total Protection” antivirus/antispyware) doesn’t know or care what radio buttons are being clicked in the user interface of a software app.

I’ve been running this way for several days, through many reboots. The new version of CPF simply will not allow itself to be enabled.

I hate to be considering an unload, yet don’t know what else to do – I need firewall protection.

QUESTION: is there a registry setting I could try changing, to “force” enabling of the network monitor?

Hint: before the upgrade, I had DISabled everything other than network monitoring, because the other tools were causing tremendous trouble on my laptop. Could there be a bug in such situations… either the upgrade or steady-state operations, when the user only enables network monitoring?

(Why disable all other elements? Mostly because at least in the old version they maintain open-file handles on lots of things, and destroy a laptop’s ability to function without always accessing the hard disk, and make it tough to put the laptop to sleep)

More info:

I backed up the registry settings, uninstalled, downloaded directly (not same as doing the semi-auto upgrade) and reinstalled. Now it works.

I backup up the new registry settings and compared… Comodo folks, you would know what this means… perhaps this is a hint of the bug?

These are the changes in the AppCtrl section:

DEAD UPGRADE SYSTEM (Can’t enable any CPF tools):
HKEY_LOCAL_MACHINE\SYSTEM\Software\Comodo\Personal Firewall\AppCtrl]


WORKING (REINSTALLED) SYSTEM (With only Network Mon enabled):

Perhaps this will eventually help others?

Hi I have similar problem after update to When I log on first time everything is OK. But when I change account(log off and log on) everything in comodo is turned off and I can’t turn it on again. Only solution is to restart. I also noticed that comodo application agent in services can’t be manually restarted.

By tools i guess your referring to the monitors. About the question, i don’t know. But given your hint, my guess is that’s it. You disabled some monitors and updating went wrong. I’m no expert, just an average user like yourself. But i just wouldn’t do that. Comodo is great for the network monitor ADN app monitor AND Component monitor AND even app behaviour analysis monitor.

Try to uninstall. Look for references on how to completly uninstall Comodo in the search function of the forum. Little Mac or other mod’s posts are reliable. But download the latest Comodo PF first.
Re-install it. It should work.

“Other software (such as my McAfee “Total Protection” antivirus/antispyware) doesn’t know or care what radio buttons are being clicked in the user interface of a software app.”

The programmers didn’t care for sure. But programs sometimes conflict with each other, and prevent some actions. Because the programmers can’t predict every scenario of interaction between the various programs, specially security programs. And now that they are in the Kernel and all that, more problems can arise. Again, i’m no expert, but it’s what i read.

I saw your next post, sorry, quick shooter here. It worked, great. But still my post is relevant.

The problems came about because of the HUGE load on Comodo’s servers during the update. It was right at this time they were trying to prepare by upgrading firmware across their systems, as they number of users has grown exponentially (just in the past month!).

What appears to have happened is that the packages downloaded from the update server were messed up in transit. Then the install didn’t go right.

My personal recommendation is to download a new install package directly from Comodo’s website, uninstall the updated install of 2.4, clean the registry, reboot, and reinstall with the newly-downloaded 2.4 install package.

In regards to conflicts with other security software… any time any software is installed, it is good to disable other security software; this is especially true when installing other security software. Real-time defense apps (like AV, AS, HIPS, Registry/file monitors) tend to cause interference, which may not be made known to the user, as they quietly block or isolate items that are necessary for the installation. Even if you set it to give notices on everything, in the time it takes to respond to the notice, the installation may already be corrupted.

Hope that helps,


I have still been having problems updating as per earlier post. As recently as yesterdayI had to uninstal and download the latest updated program from Comodo, as the previous day I accepted updates and despite numerous reboots couldn’t get the firewall to operate. As I stated previously, I love the firewall and if I have to uninstal and download updated programs periodically - sobeit!
Regarding the CIS Windows Security Benchmark, I regularly use Belarc Advisor to check the security on my computer and I download the benchmark from there. The link is:

                                                                                                      cheers - Wayne

(~Edited by mod to make url linkable.)


I have almost the same problem, and i haven’t did any upgrade (i’ve downloaded comodo fw just yesterday), tried to uninstall and reinstalling (i took the caution of first redownload a new copy).

The only “rare” thing i did was disabling the security (i tried to connect to a checkpoint vpn, no luck with that too), then, when i tried to reenable the security, just the network monitor turned on.

I’m going to try cleaning the registry, but i guess this is a bug, i’ll post here what happened


P.D. sorry by bumping and old thread, but i think it’s important, i don’t have any other firewall, and my av is Avast!, not any anti-apy software nor widows tweaker stuff…

Hi again!

I already deleted all registry key regarding comodo (under the keys mentioned above in this thread), not work, reboot and nothing… then i checked the services running and i tried to enable comodo agent by myself while starting comodo interface, and i recovered almost all services (just the network monitor was not running), rebooted again, started comodo interface, no services at all, shutted down interface, then looked at services and noticed that i haven’t permissions to enable again the service (i’m using an account with privileges), then, i just went to: C:\Program files\Comodo\Firewall and opened every executable, (cpf as last one)…

When i launched this one, i recovered all the protection… i don’t have an idea of that is happening ??? ??? ???