Interesting cpu/usage problem

I just installed CIS 4 on my main machine to give it a run down. Everything works good except one thing, whenever I download a file, it does fine until it gets to the point that it says scanning for viruses (firefox), just as that happens firefox locks up for a second, and then it is fine. But if I am streaming a video or music while a download the file that also stops responding for the second. I am wondering what could be doing this. I never had this problem with 3.14 or older.

Just to add I checked it out and saw that cmdagent spikes to 100% for 3-5 seconds and locks up the computer while it scans for viruses in the downloaded file.

Is that with large files only or with archives etc?

Hi, languy99

I did solved this by disabling the FF request for scanning. Anyway, almost all AV’s should scan the downloaded file by its own ability (FF doesn’t needs to tell to AV to do this job).

see: Firefox crashes when downloaded files are checked by virus scan | Firefox Help
scroll down to:

[i]"A new feature in Firefox 3 is virus scanning with the system default scanner after files are downloaded. With some antivirus programs, this scan may cause Firefox to crash. You can disable virus scanning in Firefox with the following steps:

  1. In the Location bar, type about:config and press EnterReturn.
    * The about:config “This might void your warranty!” warning page may appear. Click I’ll be careful, I promise!, to continue to the about:config page.
  2. Locate the preference and double click it to change the value to false."[/i]

Maybe this helps.

edit: english language on the link.

it does it with any file.

yup that fixed it but I have been using version 3 and up of firefox for a long time, and I never had the problem till version 4 of comodo. 3.14 was fine. Something must have changed, to make it behave like this way.

:-TU Thanks
At least i got rid of that annoying feature of Ff :a0
Apologies for !ot!

I had this problem with both, v4 and too.

I’m quite sure something has changed in FF on last versions (3.6 and up), b/c I did never has this on the past.

It would be nice if this solution were easy to find, so many ppl are suffering with this.

Well, I’m happy it was useful. Cool!