Intel Real Sense 3D F200 camera stops working under proactive config [M2147]

Can you reproduce the problem & if so how reliably?:
Yes, is persistent
If you can, exact steps to reproduce. If not, exactly what you did & what happened:
1.Clean install of CFW on a (clean) windows 10 system
2.switch to proactive configuration
3.after reboot camera can’t be used to login. service is not started despite being set to start automatically
5.attempt to manually start the service. Notice service fails to start.
One or two sentences explaining what actually happened:
Intel Real Sense 3D F200 camera on Lenovo AiO Touch B50-30 stopped working, the corresponding service could not be started, even manually
If a software compatibility problem have you tried the advice to make programs work with CIS?:
Yes, tried different software versions
Any software except CIS/OS involved? If so - name, & exact version:
Intel Real Sense 3D F200 camera driver version
Exact CIS version & configuration:
CFW version Proactive configuration
CFW version Proactive configuration
Modules enabled & level. D+/HIPS, Autosandbox/BBlocker, Firewall, & AV:
Does not matter
Have you made any other changes to the default config? (egs here.):
Have you updated (without uninstall) from CIS 5, 6 or 7?:
Have you imported a config from a previous version of CIS:
if so, have you tried a standard config - if not please do:
Yes, switching to (default) Internet security solves the problem
OS version, SP, 32/64 bit, UAC setting, account type, V.Machine used:
Windows 10.1607.14393.576 Home 64bit updated system, UAC on, administrator

PS. Thanks futuretech, you tried to help me with this one

I suspect enhanced protection mode is causing the conflict. You just need to attach your active configuration, the diagnostic report, and saved active process list.

i have the same problem with my paid finance software, custom build
it doesn’t run in cis10, but run perfectly in cis8
already try clean install windows and cis

:frowning: now i must revert using cis8, cause easier than costing money and time
to call the programmer to fix my software so it can run in cis10

i like cis alot, nothing out there like cis, please fix it
sorry for my bad english, not my native language


Hi futuretech
Thanks for your quick and kind response. I had some problems, trying to understand how to obtain the files. I hope the attached files, for a standard configuration (camera works in both Internet and Firewall Cfgs) and for the Proactive Configuration (camera does not work) are what you asked for.

Hi futuretech,
As promised, I come again with the updated files. I’ve reinstalled all softwares, and this time, both reported bugs (Camera stops working in proactive configuration and System cannot sleep/hibernate in any configuration) are present again and tested on a very clean system.
In the attached archive, please find the six corresponding files.
Please notify me if it’s needed to upload the (same) archive in the posted “CFW Prevents system from entering in sleep/hibernate power mode” bug report.
Thank you

PS. I mention again that the previous files were from an “altered” system, on which I’ve tested some other firewall softwares and cleaned after with a couple of registry cleaners.

Hi ctinro,

We need you help us to check the issue following below steps:
1,CIS->Security Setting->HIPS->HIPS Setting->Detect shellcode injections Exclusions(click)->add(right click)->File Groups->All applications->OK.
Restart system to check camera services, if it does not work goto setp 2.
2,Rename “cmdguard.sys” to “cmdguard.sys_”, which under C:\Windows\System32\drivers.
Restart system to check camera services, if it does not work goto setp 3.
3,Open Control Panel\All Control Panel Items\Network and Sharing Center->Ethernet->General->Properties, uncheck “COMODO Internet Security Firewall Driver” in Ethernet Properties.
Restart system to check camera services.
Please let me know the result kindly, we really want to fix this issue,thanks in advance!

Hi Flykite,
I really do appreciate your dedication to solve the issue. [Frankly speaking, for me, it’s hotter the other issue, concerning the sleep/hibernate power mode (continuous restarting)]
At the first step, the camera did not work.
At the second step (renaming cmdguard.sys) the camera worked, with a lot of applications warnings (including the x on tray icon and the red color on the widget “At Risk”), despite the Firewall was set in Safe Mode.
Thank you

Hi ctinro,
Thanks for your support!
I give you a file to replace it according to steps, please pick up it in attached file. We did some some changes in the file.
Hope it works on your side.

Hi Flykite,
The camera is working with the file you’ve sent. CFW instead, is red, with the message “At Risk. HIPS not functioning properly.”
Sorry I am late with my answers.
Thank you

PS. It seems that, with the last Tuesday windows patch (KB3213986), Microsoft and COMODO have reached to an agreement, and my system can sleep/hibernate quietly…

Hi ctinro,

Great, thanks for your help!
Could you please have a try with attached files? Rename and replace attched file following the steps that i told your, rename it to cmdguard.sys and reboot. And let me know result kindly.

Hi Flykite

I’ve tested both files and, for me, as a normal user, there is no difference between the file you’ve sent on January 12 and the files from yesterday. The camera is working fine, and CWF is red, with widget “At Risk / HIPS not functioning properly” and the x in the systray. Otherwise no messages.

Hi ctinro,

I doubt the service is not working when the file replaced as CWF wigdet in red.
Could you please to check the service status following below steps?
1,Run “sc query cmdguard” in cmd to check the service is working or not. if the service does not work goto step 2.
2,Click Notification(Bottom right of desktop )->All setting->Update&security->Recovery->Advanced startup->Restart now->Troubleshoot->Advanced options->Startup settings->Restart->Press F7 to disable signature, waitting for reboot completed.
Run the command again, then check the camera and CWF wigdet status.
Thank you.

Hi Flykite,

I’ve checked service status for both noshadow /nossdt cmdguard.sys files, according to your indications.
For both files, when the service is not working and comodo is reddish, the camera works well (as I said). Disabling driver signature enforcement makes the service working, comodo’s color is “ok”, but camera doesn’t work.
Please check the attached screen captures.
Thank you

Hi ctinro,

How about the second one? Which i provide you “cmdguard.sys” at fist time. Could you please check it in same way as noshadow /nossdt cmdguard.sys files?
Thank you!

Hi Flykite,

Sorry. I checked the first file in the same way and the result is identical (please see the attached screen capture).

Hi ctinro,

Thanks for your confirm.
Could you please have a try to uncheck “Enable enhanced protection mode…” with proactive configuration? You can find it Security Setting->HIPS->HIPS Settings, and DONOT disable driver signuture.
Thank you in advance!

Hi Flykite

This time you’re right. Camera works fine with CFW in proactive configuration (with original cmdguard.sys) and enhanced protection mode disabled.

Thank you for your perseverance

Hi ctinro,

I apologize for taking your time to help us checking issues. Let’s figure out what caused the issue.
Please try these drivers one by one, make sure to enable enhaced protection and disable driver signtature enforcement when reboot system.
Thank you!

Hi Flykite,

No problem. I really do appreciate what are you doing. The only problem is I’m a commuter, I wake up early in the morning, and I can answer to you late in the night, when I’m home.
I have a hdd with all my programs and CFW v.8 and a ssd with a clean system and CFW v.10. So it’s easy for me to switch between from bios.
Conclusion: with proactive configuration and enhanced protection mode and F7, CFW looks fine (green Lycia theme, no warnings) for all three drivers, but the camera works fine with two of them only: cmdguard-noall.sys and cmdguard-noinit.sys

Hi ctinro,

We doubt Intel Real Sense 3D F200 camera using VT when the services starting, because “enhanced protection mode” takes VT when it is enabled.
Please set procdump(attached) following steps, we can capture some infomation if the camera services crashed during starting. If you get the dum flie please share it with me.

Anthoer way, if you intalled Vmare workstation on you system you can have a look how it is work with camera services.
1, Set camera services start manually
2, Reboot system, start a vm OS, such as win10
3, Try to start camera services
Thank you!