Installs But Can't Do Anything On Net [RESOLVED]

After installing the program Firefox, Thunderbird and anything else that tries to access the internet can’t. Also, disabling CPF doesn’t help nor does closing CPF. This occurs on one of my 3 machines. The other two installs went fine. I’ve tried installing and uninstalling 2 times; downloading the install package again but nothing seems to work. Again, this only happens with one of my PC’s. If I uninstall CPF, everything works fine.

Any help is greatly appreciated.

Hi lashf, welcome to the forum :slight_smile:

There are a number of possibilities here, but a little investigation should help us solve the problem. First up, please make sure the previous installations of CFP have been completely removed. See this post for details:

I can’t install Comodo Firewall Pro

Next, we need some more information. After you have reinstalled CFP, try to connect to the net. If it works, great, if doesn’t, please post the information requested in this post:

Important - Please read before posting


OK, I’ve removed any traces of my previous firewall (Sunbelt Kerio). My system is configured in the followng:

Comodo version is
DSL through a router (all 3 PC’s)
XP Pro w/SP2
AVG Free anti virus
Nothing removed or installed other than Kerio, before or after installing CFP
AVG running at time of CFP install
No custom rules

It appears to install; it pops up alerts asking for rules. I “allow” Firefox, Tbird a mail checker and AVG. Everything looks good but I can’t get to the internet. Disabling or closing CFP doesn’t work either. I must uninstall it before I get access to the internet back.

Again, the first two machines had no trouble at all. It’s a mystery to me.

Thanks for the help.

Hello lashf

I have had this problem with version and I had to repair the winsock. You might want to give this a try if you have not already. Here is a quote from the MS website.

To repair Winsock if you have Windows XP Service Pack 2 (SP2) installed, type netsh winsock reset at the command prompt, and then press ENTER.

Note Restart the computer after you run this command. Additionally, for computers that are running Windows XP SP2, there is a new netsh command that can rebuild the Winsock key. For more information, visit the following Web site:


Thanks JJasper

I’m afraid this winsock thing went right over my head. I did not install any LSP’s. The warning about using “reset catalog” makes me very nervous. If I mess up something, I wouldn’t know how to fix it.

If winsock was messed up, I shouldn’t be able to get the Net without CFP installed, right? But when I uninstall it, everything works fine.

Also for what it’s worth, the other two PC’s had Outpost installed and not Kerio.


Hi lashf

Sorry, I thought that you could not get on the internet at all. When you said that disabling or closing CFP doesn’t work either, I missed the part where you said that you must uninstall it. You can download a small utility to do the winsock repairing if you want to even rule out that possibility by checking it. Here is the link.


Hi lashf.

A couple of things, it’s advisable to disable or remove any other security programs prior to installing CFP, and I notice you mention AVG was running when you installed CFP. This could be causing a conflict.

One other thing, when you attempt to connect, say from Fx, do you get any entries in the log files, if so what? Perhaps you could post a section of your log file here, if there are any entries .


Contrary to what many believe, one member here actually solved his issue with weird internet access (yes, he did have partial access) by resetting the winsock. It basically just resets all network & registry settings back to the default Windows state.

As far as what Toggie suggested, if you really want to be sure you can clean reinstall CFP 2.4 in safe mode.

OK, I’ve scanned for viruses and the like, closed AVG Free and installed CPF again. Same result, no Net access. I looked at the log and it is empty. I also looked at the applications section of the working CPF and for FF there are 7 entries, AVG has 3. Looking at the same section in the nonworking CPF, FF has 2 entries and AVG has 2.

Perhaps a bit of history is in order. The problem is with my old system. After I removed everything I wanted to put on the new PC, I did a defrag. Not sure if this is of importance.

Thanks again for all the help. I’ll wait for more ideas.

Maybe a hardware reality check is in order. Can one of your other machines ping, or otherwise confirm, that this PC is on the LAN? If these are machines on a wired LAN (rather than being wireless), if you swap Ethernet cables with another machine, does the problem move with the cable? Ethernet ports usually have an indicator light next to the plug that blinks when there is traffic. Is that indicator light doing anything?

At worst, open up the Device Manager ( My Computer, right click and select Properties, then the Hardware tab). The network device can have some diagnostics ability. If it does, test it.

Can’t be the cable. I have net access before I installed CFP and it returns when I uninstall CFP.

The only other thing I can think of, for now, is a corrupt installation.

On the summary screen in CFP, under Protection Strength, what does it say? Usually, if it says anything other than Excellent, it indicates a problem.

Even if it does say that, it may be worth going through another uninstall/reinstall, but before reinstalling, take a look at this post:

Manual uninstall


I just installed it again for the 3rd/4th time and same thing. I have uninstalled it to use the net so tomorrow I will try the uninstall zip file and reinstall it again and see what happens. Protection strength is “Excellent”.

By the way, I found a winsock utility and ran it. It reported “No problems found”. Also, the second time I checked the log file it had one entry in it. Something about suspicious behavior in servhost.exe and OLE was being used. Something like that; should have made a note of it.

Before I uninstalled it, I looked at the application rules in a working version of CFP and noticed 7 entries for FF, 4 for Tbird and 3 for AVG. In the nonworking PC I noted only 2 entries for each. Mean anything?

I cannot imagine what’s different about this machine. All three are configured the same.

Would version 3 be OK to try?

Something about suspicious behavior in servhost.exe and OLE was being used. Something like that;

That could very well be the cause of your problems. Svchost.exe is one of the first services to request access, normally this is for DHCP, followed by DNS. If your not getting an IP address from your DHCP server, you will fail to connect.

OK, so what do I do about servhost.exe? Create a rule for it? And shouldn’t I have received a pop up alert about this asking for what action should be taken?

I’m going to run the uninstall zip routine, reinstall CFP and see what happens.

Thanks again.

I ran the uninstall program, reinstalled CFP and I get the same result - no Net. Uninstall CFP and the Net returns.


Hope someone can come up with a solution.


Did you by chance check the CFP logs after each reinstall to see if there was anything blocked?

I did and I could kill myself for not making a note of it. It is now uninstalled. If you read back a few, you’ll see one notation about servhost.exe. This time I saw a lot of Network Monitor outbound access attempts blocked by rule ID 5. So I deleted that rule and still no access. Next I notice the source and destination were almost identical; something like and Which seemed to me to be an endless loop but I no nothing.

If you like, I can reinstall and get more accurate details.

Thanks for helping.

Few important points:

  1. If you do decide to reinstall (really appreciate your efforts for doing this so many times, BTW
    ), try to do it in Safe Mode. This works only for version 2.x, not 3.x. Reboot into normal mode. Afterwards as it’s installed and you try to connect to the internet, right-click in the Log window, export to HTML, edit the log file to mask any private IP addresses, and save it as compressed file or .txt so you can upload it here.
  2. Are you certain it was servhost.exe and not svchost.exe? Because the first one isn’t something I’ve ever seen, while the second one is a legitmate and important Windows file that affects the internet connection.
  3. If you’re networked/connected to more than one computer in your local area, you’ll need to define a trust network in CFP: Security > Tasks > Wizards > Define a new Trusted Network.

OK, installed in Safe Mode, rebooted and still can’t get to the net. Attached you’ll find the log file.

Can’t remember if it was “serv” or “srv” now. Thought it was the former.

No network, just DSL through a router with 3 machines connected by wire. The other two installations went without a problem.

Thanks for the help Soyabeaner. Hope you can figure this out for me.

[attachment deleted by admin]