Installing via Remote Desktop w/o getting locked out?

Basically, I’m wanting to install Comodo on a single-purpose remote machine that I will not have physical access to (A Dedicated Virtual Server I’ll be renting in a data center 2,000 miles away). First, I am attempting a Remote install on my test network. (Server 2003) I can Remote Desktop in just fine, download and install Comodo without problems…but after the initial reboot I am obviously locked out. How can I set an initial policy to at least allow inbound TCP port 3389 traffic after the first reboot during the installation process so I can re-establish my Remote Desktop connection?

Welcome to the forum.
Have you tried to set up a network monitor rule before you reboot after the install?

Welcome to the forum. Have you tried to set up a network monitor rule before you reboot after the install?

Thanks for the response. I’m not sure what you mean though. Could you either explain or point me in a direction to read about creating “network rules”? If this is a Comodo rule…Comodo wouldn’t allow me to make any rules on initial install until after the initial reboot (all Comodo services showed as “disabled” until the reboot process to complete the install)…which is obviously too late. Even so, I tried setting Comodo to “Allow All” prior to the initial reboot and the setting was not saved.

I considered creating the rules on a local test-server that I have physical access to, then copying the .dat file w/ the rules over to the newly installed machine…but I don’t know if that would cause problems seeing that it is a different IP, different MAC, etc…I tried a hex editor on the .dat file but nothing seems to be human-readable in there…via text or hex editors.

I meant that you should make a network monitor rule in CF, but you have tried that without any luck…
There is a script,2366.0.html
that can save the rules and settings, but since Comodo has a registry protection you need to come in and turn it off and set the firewall to allow all while putting in the registry settings. Hmmm…
I suppose you can’t run the script before install… :o
Maybe if you make that reg file run at startup…??? Cf will probably protect the reg at startup too…

I really don’t know how you should make this work…
Maybe make a trip to your router… :wink:

If you want help with this, I suggest that you submit a support ticket to Comodo, if you don’t get anyone else here to help you with this.


The script might be the easiest way out of this, but you’d need to do a local install first that included the port settings the remote access requires. You could then run the script to capture the ruleset and then install the .REG file on the remote PC after installing CPF but before the reboot.

Thats the only way I could think of to do this.

Hope this helps,
Ewen :slight_smile:

Doesn’t the install process ask if you want the auto setup or manual setup. I haven’t tried the manual setup so I don’t know whether that puts any rules in Network Monitor or not. Could that be a possibility? That might allow you to put the rule in when you are installing it or maybe manually means that there are no rules put in at all and then you could log in and merge a .reg file.


UPDATE: Just did a reinstall of latest version using “Manual” and it doesn’t let you change much. One thing that might be tried is it allows you to specify a trusted zone. You might be able to pass off your ip address so that it will give you access for all both ways.

Okay, I installed on my test server, opened TCP port 3389, rebooted, ran the backup script mentioned above and saved the reg file. Then I uninstalled Comodo and started over.

Upon installing Comodo again, I went through the install process, didn’t reboot, fired up comodo, disabled the “monitor comodo’s registry settings”, merged the reg file, rebooted and it worked like a champ.

New Problem: I just did this on a “real” remote server. I didn’t get locked out, but I am having serious problems. Comodo doesn’t show up in the process tab in task manager and there is no system tray comodo icon. Comodo doesn’t even show up under C:\Program Files. When I try to reinstall, I get the error:

“You seem to be having Comodo Firewall installed using older version of installer. Please go to ‘Start->Control Panel->Add or Remove Programs’ section and un-install Comodo Firewall.”

Comodo isn’t listed there. It isn’t in my start menu, and it isn’t in the Program files directory. What reg keys do I need to delete to try again?

The current Version key is hex 2335

as far as I know that was what the current d/l file put as a key. should I try decrementing that key until my setup file works? Do I need to restart between changes? Does anyone know what value I could pop in that key to avoid this error?


Solved it by only exporting the rules keys instead of the whole Comodo tree.