Installing extension problem

I’ve been using CD for a few days and really like it. I’m having a problem installing the Youtube extension.

After clicking on “Get more extensions”, then clicking on Youtube, and confirming the installation… I get a message that says Extension Install Failure…This can only be installed from Web Store.

I thought I was already in the Web Store. What am I doing wrong?

Can you please post a link to the extension you’re trying to install?

Also, I’ve moved this to the Comodo Dragon board. :wink:


Here’s the link… I got here from Tools > Extensions and then clicking on ‘Get more extentions’.

Hi oguy,
This workaround by Forum Member wasgij6 found here might solve your problem.
Option is found in Dragons Menu, Under the hood.

captainsticks, I did what wasgij6 recommended and it looks like it did something because I did not get the previous rejection message and it seemed to install ok. The strange thing is that it does not show up on my Extensions. I also don’t have any icon up on the right corner of my address bar to let me launch Youtube. In other words, I don’t see it in CD. But I can now launch Youtube from the web store itself (Chrome Web Store). So that’s something, but it won’t be useful to me.

Hi oguy,

Another workaround you could try is downloading Dragon installer from Comodo site. Launch it and choose repair. Don’t shut down the internet connection during repair.

Boris, I’m looking back through the installer steps (link below) and don’t see an option to repair.

As Dragon is already installed on your computer, if you run the installer it will present you the choice to repair or uninstall.

Thanks Boris! I ran installer and it presented the options you mentioed. I clicked on repair and that went ok… pretty fast too.

Then I checked my extensions and still, no sign of Youtube anywhere within CD.

When I went to Chrome Web Store and ran the hand pointer icon over Youtube, a clickable green window showing ‘Launch app’ appeared. That’s what was happening before I did the repair… things haven’t changed at this point. I can launch it from CWS but not from CD.

Sorry to read your problem persists. Repairing Dragon with internet connection on allowed me a few weeks ago to solve a very similar problem encountered by a friend who couldn’t install any extension, reason why I suggested it.

I found a workaround solution. I installed an extension called Extensions Manager (aka Switcher). It installed just fine and placed an icon up in the top right (on address bar).

When I click on the new EM icon, it shows every extension that I have, the ability to uninstall each one, enable/disable, and other info. It’s a control panel for all your extensions. Pretty nifty.

My extensions however, do not appear when I do Tools > Extensions . Is there some setting that’s preventing that from happening? Extensions Manager had no problem finding them.

I am having a similar problem to the one that the previous poster “solved” by installing Extension Manager. I did get EM into the CD extensions folder - but it doesn’t show up in the right hand corner like it did for them.
The reason I am trying the use of EM is because other extensions for the store also do end up in the CD extensions folder but never show up in CD itself. I have tried shutting down CD & starting from scratch but the extensions just do nothing. DId successfully install 2 from the CD website - just nothing from the Chrome store.
Any ideas?