Installing COMODO Time Machine is hanging

I’m trying to install Comodo Time Machine on XP SP3 on a Dell Latitude D830 laptop.
The installer looks like it has installed everything under Program Files/Comodo/Time machine
and the icon has appeared on the desktop. But the COMODO Time Machine Setup window seems hung,
showing Installing COMODO Time Machine, Please wait while the Setup Wizard installs COMODO time machine.
And the Back and Next and Cancel buttons are all greyed out and cannot be selected.

Process Explorer shows ClientService.exe has been started by msiexec.exe, but
it’s been hung about 40 minutes now, and nothing much is going on on the system.

This hang has happened twice now; I killed it and uninstalled and tried again.
Any logs to look at to figure out why it is hanging?
Any workarounds?

[attachment deleted by admin]

The command that is hanging is
“C:\Program Files\COMODO\Time Machine\ClientService.exe” -service
which seems like it is supposed to install the service.
If I run Services, I don’t see an entry for Comodo Time machine.

So I manually ran “C:\Program Files\COMODO\Time Machine\ClientService.exe” -service
and this did install the service.
And then I killed the ClientService.exe started by msiexec.exe and the
Comodo Time Machine Setup finished and told me to reboot,
and I did and everything appears to be working.

I tried installing on another XP SP2 Home edition system and it hung there too.

Any ideas why “ClientService.exe -service” is hanging when run by msiexec.exe?

Moderator - please move this to the bug forum if it belongs there.

Hi, rjbutera,

Thank you for your information, we are investigating this problem.

Best Regards,