Installing Comodo Disbled Pen / Digitizer on Tablet PC

I just installed comodo on my Fujitsu tablet. After reboot, the pen is not working ???

To verify, I uninstalled Comodo, and the pen started working again.

Re-intstall Comodo, and after reboot same behavior.

To be clear, disabling comodo does not restore the pen functionality. Only completely uninstalling Comodo.

I tried uninstalling the pen driver, and installing it after Comodo was installed. Comodo gave no errors or messages during that process. The end result was the same. The pen is still not working.

At a loss. I submitted a trouble ticket.

Can you show a screenshot of the Defense + logs? They can be found under Defense + → Common Tasks → View Defense + Events.

I reinstalled COMODO, and took this screenshot. I notice three entries that appear related to the pen.

Having that clue, I disabled Defense+ rather than uninstalling COMODO. After reboot, the pen comes back to life!! Now I at least have the firewall working. What should I do next?

[attachment deleted by admin]

Do the logs say that one of the Pen applications get sandboxed?

Can you see if there are files that belong to the Pen application in My Pending Files (Defense + → Common Tasks)? If so, try moving them to My Own Safe Files.

There is nothing listed in the “My Pending Files” list.

I re-oriented the screen and took a better shot of the defense plus log for you. I am attaching it.

I just noticed something strange. The Defense+ events log refers to “C:\Program Files\Tablet\Pen\Remove.exe” There is no directory called Tablet in my Program Files. (Yes, I do have view hidden and system files turned on…) A search of the c drive finds no “remove.exe” anywhere.

[attachment deleted by admin]

The alerts are from April 19.

When you can’t find these files it looks like you may not have the driver installed at the moment. May be you uninstalled it while testing and forgot to install it again?

I have not uninstalled the driver. When I first started troubleshooting, I did try installing the driver after I installed Comodo, but that did not fix the problem. So far, only uninstalling Comodo completely or disabling Defense+ restores the pen / digitizer.

It works, when you have disabled D+ by right-click on system tray CIS icon ->D±>Disable, or after you have disabled it permanently in CIS->D±>Advanced->D+ setting-> disable D+ permanently?

After I have disabled it permanently.

And what if you just disable it through right-click on the CIS system icon?

I unticked disable permanently and rebooted. I then plugged my usb mouse into the tablet and ticked disable in the tray icon. This did not re-enable the pen. I rebooted again and still no pen.

While I was at it, I tried rebooting in clean pc and training modes. None of these enabled the pen.

After doing all of that, disabling defense+ permanently and rebooting the Pen still did not work ???

I uninstalled Comodo, rebooted and the pen started working again.

I reinstalled Comodo, and used my mouse to disable defense plus, but now when I restart the pen still does not work.

I then tried reinstalling Comodo with the “firewall only” option, and again the pen stopped working. I have now uninstalled Comodo altogether.

sderevyanko, here are the files you requested.

[attachment deleted by admin]

Hi LambdaFox. From what I see you have found a compatibility issue. I will move this topic to the bug boards.

Could you add your system information as described in IMPORTANT: HOW TO SUBMIT BUGS (read this if you want them fixed)? That would greatly help the devs to tackle the problem.

  • CPU (32 bit or 64 bit)
    mobile Intel Pentium III 933

    • Operating System information (including Service Pack Version)

Microsoft Windows XP Tablet PC Edition 2005
Version 2002
Service Pack 3

* Actively-running security and utility applications  (Optional if you post a  Comodo Firewall Pro Configuration Report)


* Specific symptoms of the bug, and steps you can take to reproduce it (step by step).

Install CIS. On reboot digitizer & pen stop working.

* Specific steps you have taken to try to resolve it.

See thread above

* Brief description of your Defense+ and  Firewall+ mode (Custom, Train with safe) plus mention if you modified any setting in ADVANCED section of D+ and F+ (Optional if you post a  Comodo Firewall Pro Configuration Report)

See thread above
* If you pc reboots or you have a BSOD post in BSODs: Please add your minidump files here
Not applicable

* Report if you are using an Administrator account Or a Limited User account. Vista users please Report if you have UAC Disabled or Enabled (Optional if you post a  Comodo Firewall Pro Configuration Report)