Installed Comodo and can't connect to Internet

I’ve installed Comodo, I’ve set my trusted network, svchost.exe is set to allow, Firefox and IE are set to allow and I am still unable to connect to the Internet. I know that this is someting very simple, but I’m pulling my hair out trying to figure out which setting I’ve hosed up.

A few comments about my set up:

  1. I am using both IE and Firefox (can’t connect using either program)
  2. I have a Linksys wireless router (54G)
  3. I am attempting to connect through a cable modem

Let me know if you need any additional information. I’ve attached the a screenshot of the activites log.


[attachment deleted by admin]

Welcome to the forum scruffed1,

I am assumming that you are using version 2.4 of the firewall.

Can you connect to the internet with the firewall set to “Allow All”? Go to the tray icon, right-click it and select “Allow All” and try to connect to the internet.

Just some things to check:

Did you set up a Trusted Zone using the firewall or did you write the Trusted Zone rules yourself?

If you set the rules up yourself are they at the very top of your Network Monitor list? The block rules in the list should be at the very bottom.

You should have a default rule that allows everything out and it should be above any block rules in the list.

Make sure that all of the allow rules are above any of the block rules.

hope this helps,


Thanks for the reply Jasper. I set up the zone through the firewall and used the Comodo settings. I have an entry at the very top of the Network Monitor list that allows everything out from the zone and the next entry allows everything into the zone. At the moment, I do not have any block rules set up. I am using 2.4 and everything works just fine when the firewall is set to allow all.



By not having a BLOCK ALL IP-IN rule at the bottom of your Network Monitor list you are allowing anybody in that wants to get in which is the same as no protection at all. You should have a block all in-IP rule at the bottom of your list of rules as the log is blocking everything going out it looks like.

Could you do a screen shot of your Network Monitor list so we could have a look at your rules. Please either change or block out your actual IP addresses before you post them. Maybe we can see what is causing the problem.