Installation Rollback Failure

After the late February update of Comodo Firewall, I couldn’t open any applications. After much futzing and research, finally figured out that the latest version of CIS for Vista 64 bit had problems so I uninstalled it and everything worked again. Great news, but now am operating with Windows Firewall :o.

I don’t know for sure which version was installed when the problem started. I allowed Comodo to do an automatic update so once I uninstalled it, there was no indication left behind to tell me which version it was.

I read the notes on the latest version, .477, and it said it fixed the problem with applications not running, so I downloaded it and tried to install. No luck. It gets all the way to the end and pops up a window that says Rollback Complete. I tried turning off Avast and making sure all Avast processes were killed, I tried installing to a different directory, I tried deleting all relevant entries in the Registry. Still won’t install. I noted, however, that there are certain entries in the registry that I cannot delete, keys similar to the following:

The failed installation left behind a Repair directory with a copy of cfp.exe in it. So I ran that and it came up with a message that Comodo was not installed and would I like it to repair it? So, of course, I said yes, and, of course, it failed again, but it left behind a log file, which I have attached in case it holds some clue.

Any thoughts?

[attachment deleted by admin]

You can remove Legacy keys if you follow the instructions Here.
But I would not do this unless you are entirely happy to manually clean the registry.

cfp.exe on it’s own could not repair the complete install, it needs much more files to “repair” you can see that in the diagnostics file, almost every file has a NO after it, that means the files are missing.

I would delete that “repair” stuff and then try again to install, the LEGACY_ keys should not cause installation rollbacks… please also check to see if this is also a problem for you:

Not that it keeps telling you to update, but there could be some files left in the VirtualStore…

I manually clean the registry on occasion and I’m fine with that. But I’m a little scared to try deleting legacy keys because when I tried before, it did a partial deletion of the key and then failed, which resulted in making my network adapter stop working. I had to roll back Vista to bring it back. Of course, I am not entirely sure it was the Legacy key that caused the problem since I deleted a bunch of keys containing the word comodo at the time, but it was the only key that gave me trouble. It happened twice when I tried to delete a Legacy key but did not happen when I deleted all other comodo keys except the legacy keys.

There is nothing in my VirtualStore.

I had deleted the Comodo directory containing the Repair files before trying the install.

Other thoughts?


Rollbacks are normally a result of a detection that the OS is incompatible with the installer version of CIS.
Can you post your OS details and the name of the installer used ?

You could also try to install 3.5.x and see if that also does a rollback, then it would be caused by something the installer is trying to “overwrite”.

OS is Vista Ultimate Ver 6.0.6001
Installer is CIS_Setup_3.8.65951.477_XP_Vista_x64
Found a copy of CIS 3.5 64-bit and downloading now. Will report back.

The 3.5 install resulted in a rollback as well. The install file was CIS_Setup_3.5.57173.439_XP_Vista_x64.exe. Even worse, it resulted in killing my networking controller. I couldn’t figure out what the problem was so I had to do a system restore to a point prior to the installation. Then I thought I would try manually removing Comodo entries in the registry. I carefully avoided the Legacy keys. Sure enough, it killed my networking controller again.

Strange, I’ll see if i can find something that could be causing this…
I would be surprised that this could be caused by the legacy key issue, this is no problem on the x32 bit version, but then again x64 is more strict so I’m not sure…