installation problem

(:KWL) Good day.
Well, I searched before this post but could find no help, so I am starting :
Today I installed firewall (winxp pro sp2), within installation I asked to uninstall third party application so I cancelled installation, removed Macafee then started again, I got a message that I have an older version and asked to go to control panel and remove existing Comodo firewall. when I went there I found no one there. I cleaned registry, deleting history, went to program files and found empty folder also I removed it, still not able to install.

Please help.

Greetings and welcome to the forum, sinan ~

I’m sorry you’re dealing with this problem; however, I am confident you can get past it! :smiley:

Here’s a couple things to check off the top:

Go to Start/Run, type in “services.msc”

Look for an entry titled “Comodo Application Agent” or similarly titled, about the Comodo Firewall (while you’re there, make sure there’s no McAfee entries as well - McAfee is, in my experience, notoriously hard to get rid of). If you have any Comodo Firewall entries, double-click and change the startup type to “Disabled”, Apply, Okay.

Go to Start/Run, type in “msconfig”

Go to the “Startup” tab, look for the “CPF” entry. If it’s there, uncheck it.

Reboot. Run your registry cleaner for all instances of Comodo Firewall. Reboot.

Check the first two items again, to make sure they’re not active (they should be gone…).

Make sure you have the latest release version of CPF downloaded from Comodo, here: http://www.personalfirewall.comodo.com/

Run the installer. Be sure to reboot after installation.

Also be sure to post back with your results…

Hope that helps,

LM

Thanks Little Mac.

I will beging with Mcafee, I am running removal utility from Mcafee that is cleaning all Mcafee entries everywhere so I am cleaned. (it is mcpr.exe - trying to attach it to this message in zip file but I got a message saying file is too big - 325680kb)
I tried all you mentioned but still getting same problem (:KWL) -don’t be worried, I have enough knowledge to manage such things.

Question is comodo is disabled now on services, not placed in startup, I cleaned registery using more than registery cleaner, I believe it should be removed from services. Is there a way or other to remove it forever ?. Or suggest what to do next.

Thanks again and have a nice day.

Let me do some digging around, see if there are some specific CLSIDs or other registry keys to remove so that it disappears entirely.

LM

I’ve used the McAfee removal utility before; it was not very effective on my machine. It still had components in Add/Remove programs that could not be removed, files/folders that could not be deleted… I had to search the registry with Regedit and remove all traces of McAfee before it was entirely gone.

Here’s a couple things to check out, sinan…

https://forums.comodo.com/index.php/topic,302.0.html This provides command line instructions for manual removal of CPF (an early version that was installed using Installshield). It may or may not work for you. Here is the exact quote from umesh with Comodo:

" i)Go to “Start->Run” and type “cmd” in combo box and press OK button. It will open DOS console window.
ii) Use 'cd" DOS command to change directory to CPF installation directory, which is by default
‘[Program Files Folder]\Comodo\Personal Firewall’, so if you have OS installed in ‘C’ drive, it should be
“C:\Program Files\Comodo\Personal Firewall”.
iii) type in “fwconfig -uninstall” and press “Enter” key.
iv) A dialog box will appear, there after just follow it to un-install CPF.

  Above method removes Comodo Personal Firewall configuration from system, but still files will be there in installation directory, that you can delete manually."

Here’s a second link, to two posts by Bullhorn. He experienced almost the same exact problem as you. He doesn’t give much detail, but was able to resolve by registry editing. Perhaps a more thorough Search in Regedit? Or a software like RegSeeker, etc? https://forums.comodo.com/index.php/topic,1184.msg25933.html#msg25933

Hope this helps; let me know…

LM