Installation problem - Problem with dealing with shortcuts

Yesterday I reinstalled the two separate partitions - saved via Acronis TrueImage - on which I have respectively my OS (XP) and my apps (CPF included). No problem, however as they dated from August I had a previous beta version of CPF and when I tried to install the latest version I was asked to uninstall it.
I did it successfully, however with the install of the updated version we got up to the point where I selected automatic settings - I am no power user :slight_smile: - and then I got the following message:

Problem with deleting with Shortcuts. Please kindly delete the shortcuts manually
See the image below for details. I tried a new install, and I was warned that there was a previous version - which was the previous failed install. Cleaned the related registry keys with a registry manager, tried a new install and I got the green light to proceed, but the same exact problem happened. Went thru the same iterations with two other fresh downloads of the CPF installer, to no avail. Moral I cannot install CPF, any help is welcomed flash

[attachment deleted by admin]

Did you get rid of them on the other partition as well? I would assume so but had to ask. I think this may have to do with dual partitions. Do they bother have an active OS or is one just a backup?



Paul, i am not sure about your question, so forgive me if I am not to the point:

  1. C: is the active OS and D: has just apps - no OS backup
  2. the Comodo beta was installed on D: and that is where I tried to install the up-to-date version
  3. Previous to yesterday when I reinstalled the two partitions, I had the same setup (C: XP and D: apps) with the current version of CPF working fine


<Paul, i am not sure about your question, so forgive me if I am not to the point:>

No problem, now we’re even it seems, lol. :wink: However , I see what you mean now.

Try going here…,302.0.html

I think this may be a better route for you to take. :slight_smile:


Thanks for the link, Paul, I’ve posted there about my problem.

In case any error is encountered during installation of product, installer rollsback.
The message you are seeing is an error when it tries to Rollback, i.e. removing the shortcuts and files copied.
Before this it should have showed the error b’caz of which it is rolling back!
But seems this is the only message you got, so please check out following things:

  1. Are there any files from previous installation in chosen destination folder.
  2. Did you see firewall configurator dialog

It would be helpful if you could please attach snapshot of the installer before you get this error.

Problem with deleting with Shortcuts. Please kindly delete the shortcuts manually

I have this problem too
Where this shortcuts that I must delete manually?

I have this problem, too. A Google search turns up no solutions – somewhat puzzling for a released product with a fairly wide distribution and reports of the problem dating back a year or more.

To answer umesh’s questions:

  1. No. I never installed this product before.
  2. Unclear. Whatever text there is before the “Rolling back 100%” message (if any) appears flashes by so fast that it is unreadable.

There is nothing before I get this error – just normal progress, then a dialog box pops up, with “Rolling back 100%” in a background window with title “COMODO Firewall Pro Installer” and a foreground dialog box with “Problem with deleting the Shortcuts. Please kindly delete the Shortcuts manually.”

I had the same problem, but …


I didn’t wanted to have a malware scan. When it asked me if I’m sure that my computer is clean I clicked 100 times Yes and it made the Rollback and so on.

But just I tested to click No and it worked correctly.

Are you sure your computer is clean?