installation of canon camera ixus 55

hi there everyone!!!

i cant get my canon camera to install properly on my computer. I think it is because that my comodo firewall came up with a allow/block sign and i blocked the required download or entry for my camera. how do i reverse this process?

os: windows 7

thanks very much!!

please help!


Welcome to the forum ixus :slight_smile:

If it is on the install please try

Defence+ /Advanced / Computer Security Policy

You should find the entry at the top of the list.


Edit If it is download please try

Firewall /Advanced / Network Security Policy
It should also be at the top of the list here aswell

hi dennis. I did it about 3 weeks ago so i amunsure which entrance it is. Even if i did find what option should i take; remove, purge…? thanks for your help hope to hear back.


Just remove it,though you can try purge if the application is not on your computer.


hey dennis. tried to locate the specific issue. went on and troubleshooted the issue and came up with this error message
this isnt comodo right…?

Windows cannot start this hardware device because its configuration information (in the registry) is incomplete or damaged. (Code 19)

thanks for your time


That sounds like your driver is not installed properly. Do you have an installation CD? Run the "driver installer from the CD and when you get an alert for the installation program put CIS in “Installer or Updater” mode.

i dont have the installation cd. I have tried installing the driver and uninstalling it. any other suggestions…?


1.Change CIS mode to ‘Traning mode’(Firewall, D+)
2.When you install the driver and canon tools, run as Administrator.
3.Overwrite all of drivers.
4.uninstall all of them.
6.reinstall the driver ‘run as Administrator’. canon tools and check you camera is working.
8.if it works fine, change CIS mode to your default mode.

What is you Windows 7?
x64, x86?
Build number?

hey thanks for everything. i have sorted it out!!!