Installation failure

I had a CIS failure which led to having to remove CIS. When I came to re-install, the installer allowd GeekBuddy to load then said that the old version needed to be removed even though it already had been.

I ten downloaded the reval tool, 0.3b, which I then ran. Tried re-installing, same result! I then used JV16 to check registry and for any files with Comodo or CISPremium in the filename and removed them.

I have just tried to re-install yet again and, guess what, exactly the same problem.

How can I get CIS to install???

Hi JulianH,
Please try the unofficial clean-up tool in windows safe mode.

Already done, hasn’t made any difference at all. JV16 was also run in safe mode. Have also checked with Malwarebytes and SuperAntispyware.

CIS just will not install >:(

You could try running the Windows Installer CleanUp Utility, using caution to only remove CIS & Geekbuddy related entries.
This could remove installer information from previous installs, which could be blocking the new install.

Windows Installation Cleanup Utility has been withdrawn due to it damaging system files

Important Information
Where is the Windows Installer Cleanup Utility (MSICUU2.EXE)?
This article previously contained a link to the windows Installer Cleanup utility also known as MSICUU2.EXE. If you were directed to this article to solve a problem installing or uninstalling a product other than Microsoft Office, click the following link to use the replacement utility to uninstall your program:
Use the Program Install and Uninstall troubleshooter

This Fix-it does not help as neither CIS nor Geek Buddy are shown on the list and a full code is required if a programme is not listed.

For information my system is running Windows 7 Ultimate x64.

So where do I go now to make CIS install???

Sorry nothing is working. :frowning:
Have you had any other previous Antimalware products, if yes try running the corresponding uninstallers here if it is listed in case of any remains.
I will ask the other Mods to take a look at this topic and I think one of them has a list of possibly conflicting/interfering registry keys.

Edit: If Geekbuddy is not required, you could try leaving Geekbuddy out via custom install.

Did you try running a registry cleaner?

Please use Windows Cleanup Utility. I have used it various in the past to good effect. It only removes installer related information. In your case you would need to let it remove the information for Geekbuddy.

When the installer related information is gone the installer will think the program is no longer installed. When there is no service or driver of Geekbuddy running the installer should be able to do its job.

Let us know how things go.

As I said earlier, the Windows Installation Cleanup Utility has been withdrawn! It is NOT available to download.

Earlier today I tried GeekBuddy and dealt with Sean. he tried all the methods I had used to get CIS to re-install and after 1.5 hours still could not get CIS to install. At this point I had to go out and was told to contact GeekBuddy later.

I have just run the following in this order: In normal mode - Comodo IS Uninstaller, Comodo Removal Tool (May 2012).bat, Comodo Support Tool.exe, Microsoft Fixit I also ran all of these again in ‘Safe Mode with networking’. I then ran JV16 registry clean and registry search. The only Comodo files it could not remove from registry were Comodo Cloud Scanner update.job and Comodo Cloud Scanner update.job.fp After this I then ran cispremium_installer.exe and it yet again only installed GeekBuddy giving Error 1612 - The installation source for this product is not available.

As GeekBuddy had installed, I tried using it again with the following result:

Jonas (08/24/12 19:41:18): Hi, I am Jonas from Comodo. In order to benefit from our services you would have to subscribe by creating an account here: GeekBuddy Shopping Cart -> Bluesnap Here is what is included in the package: Are you looking for Remote PC Support & Online PC Help from GeekBuddy

Not exactly what I was expecting - Sean was much more helpful!

What is the matter with the uninstall programme that it needs a Removal Tool and a Support Tool to remove registry and file system leftovers and, of course, why is the installer yet again giving Error 1612 - The installation source for this product is not available?

Is there anyone who can give any idea of how to cure this problem or do I need to forget Comodo and go for another programme, which I would prefer not to?

Removed CIS again! Have run all tools again in SafeMode. This is what JV16 gives as an error when cleaning Comodo items from registry also in Safe Mode (Administrator Acct):

[20:40:09 - Error]: Failed to remove “HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Schedule\CompatibilityAdapter\Signatures : COMODO Cloud Scanner Update.job”! Windows core returned the following error: “Access denied or invalid key (PT)”
[20:40:10 - Error]: Failed to remove “HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Schedule\CompatibilityAdapter\Signatures : COMODO Cloud Scanner Update.job.fp”! Windows core returned the following error: “Access denied or invalid key (PT)”

I thought Norton was difficult to remove but this really takes the biscuit!!

For Windows Installer Cleanup Utility download it from Softpedia: .

Downloaded the cleanup utility - noticed this in the readme:

Msicuu.exe now works with all 32-bit versions of Microsoft Windows.

I am running 64bit Windows 7 so is this programme actually able to see what is occuring??

Tried running it and NO Comodo programme shows in the list. So what next???

I see we forgot to point you to Jacobs Comodo Uninstaller tool. This has the ability to remove Geekbuddy left overs. When needed run it in Windows Safe Mode. Let us know if that helps.

Do you need Geekbuddy? If not then do a custom installation in which Geekbuddy does not get installed.

Tried Jacobs Comodo Uninstaller tool, GeekBuddy’s Comodo Removal Tool May 2012.bat and GeekBuddy’s Comodo_Support_Tool.exe and have checked that there are no apparent Comodo files, registry entries etc. Tried running cispremium_installer.exe and, yet again, GeekBuddy installs OK but CIS fails with Error 1612 every time!!! It doesn’t matter whether I do or do not want GeekBuddy installed, CIS installation fails with Error 1612!

I have tried all methods of removing then re-installing CIS and all have so far failed miserably. All files etc have been removed - I checked the contents of the files and checked all locations for files and for the registry entries and all have been removed. The removal tools have done their job but the cispremium_installer.exe file, which is a new download every time, fails with ERROR 1612. Why??? >:(

Is there anything else that GeekBuddy, this forum or myself have not done that will allow me to install CIS again???

That MSI installer related error is a real pain in the neck. See if this solution brings any solace to your situation: .